Camera not detected in Raspbian Buster

I purchased a couple of ArduCAMs. One is straight up 8mp, and the other is a motorized 5mp camera.

I am not able to get Raspbian Buster to recognize either ArduCAM camera. I can plug in the Raspberry Pi official camera and it works fine. I’m interested mostly in the motorized focus camera (for Octoprint).

vcgencmd get_camera says “supported=1 detected=0”

Any ideas?

Meh, no response here or on Amazon and no tech support. Guess I’ll just return them and find another option.


I’m sorry to reply you so late. I’ve been very busy recently. Don’t worry, all our products are guaranteed. If the camera is defective, we will give you replacement for free.

vcgencmd get_camera says “supported=1 detected=0” which means the system does not detect the sensor’s i2c address. Most of the reasons are due to poor wiring contact.

If you have ensured your hardware connection, please tell us and we will give you a replacement. Sorry again to reply you so late.




I’m having the same issue, bought 2 on amazon. One worked fine, this one is not… i have tried everything from changing ribbon cables, reinstalling octoprint, changing all the settings in config.txt with ssh multiple times with multiple settings and nothing, i mean nothing seems to work.

@spazmiacanacama Hi,I’m sorry this happened, we need some more details.

  1. Where did you get the camera module(s)?
  2. Model number of the product(s).
  3. What hardware/platform were you working on?
  4. Instructions you have followed. (link/manual/etc.)