B0241 not detected

1.Which seller did you purchase the product(s) from?

2.The Model number of the product(s) you have purchased?
B0241
3.Which Platform are you using the product(s) on?
Raspberry Pi4 4GB
4.Which instruction are you following?

5.Has your product ever worked properly?
Nope. Cannot get it to work the 1st time
6.What problems are you experiencing?
Hello,

I get the following error message when I enter the command -> raspistill -t 0:

mmal: Cannot read camera info, keeping the defaults for OV5647
mmal: mmal_vc_component_create: failed to create component ‘vc.ril.camera’ (1:ENOMEM)
mmal: mmal_component_create_core: could not create component ‘vc.ril.camera’ (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: camera is not detected. Please check carefully the camera module is installed correctly

The camera is connected correctly -> Camera-HDMI cable-HDMItoCSI. With a original HQ Pi Camera, all is working well.

Please advise.

Thanks,
SW
7.What attempts at troubleshooting have you already made?

8.How would you like us to help you?

Hello,

Don’t worry and I will try my best to help you.

Firstly, I advise you remove the HDMItoCSI connector and connect the camera to the PI directly.

Then reboot the system and run the ‘vcgencmd get_camera’ command to check if the camera is exist. If normal, you will see the message ‘supported =1, detected =1’ In this case, you can use raspistill -t 0 command to run the camera.

If anything is normal, which means your camera is normal. Let’s move on the HDMItoCSI connector. Just to connect the camera to HDMItoCSI connector. Please ensure the connector is normal. Then retry the above command to check the camera. If the camera is not detected,

Maybe the connector or the HDMI cable is defective.

 

Hello,

The HDMI cable is faulty. How can I get a working replacement?

Thanks!

Please contact our [email protected] .