Arducam ToF Camera is not working with Jetson Orin Nano(Low FPS, No Depth Data)

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)?
    Arducam Tof Camera (Lot Code : 20230510 | Model No: B0410)

  3. What hardware/platform were you working on?
    NVIDIA Jetson Orin Nano Developer Kit(8GB)

  4. Instructions you have followed. (link/manual/etc.)
    Getting started: Arducam ToF Camera for Jetson - Arducam Wiki

  5. Problems you were having?
    I have followed all the instructions from the above link and compiled the package. I am getting this:

    Very Low fps as you can see from the screenshot.No depth data at all.

  6. The dmesg log from your hardware?
    Out of Charecters

  7. Troubleshooting attempts you’ve made?
    I have found some open issues on the arducam github page with similar problem and the solution was the external power. I have checked the power pins multiple times and it is correctly connected.

  8. What help do you need?
    Please guide me what are the next step of trouble shooting.
    I really need this Camera to work.

Let’s discuss this here. We are checking this problem. Please stay tuned to the thread.

1 Like

Please run the command below in the command line and post the output here:

v4l2-ctl -d 0 --set-fmt-video=width=240,height=180,pixelformat='Y12 ' --stream-mmap --stream-count=-1
1 Like

After entering this command no response is coming…waited 5 minutes then I exit. I tried again but no response is coming.

Is there any update on this problem?

Hi @Dion
My problem is not yet solved, but I did this:(this is what I got in return)

is it possible that as opencv does not support Y12 format that is why this problem is occuring?(not sure)
Let me know what do you think?
if you have any other solution to fix this issue please let me know.

Hi @Dion , is there any update? Please respond

Hi guys,
If you have faced a similar problem, please change the TOF camera to connect the CAM 1 port on your Jetson Orin Nano. That will make sense.