Arducam MultiCamera module problem?

Hello,
I’m using an arducam multi camera adapter v2.2. For the moment, I’ve two camera connected. Before I start the camera, I write these commands:

sudo apt-get install python3-pyqt5
sudo apt-get install python3-opencv
sudo apt-get upgrade
sudo apt install -y python3-kms++ python3-libcamera
sudo apt install -y python3-pyqt5 python3-prctl libatlas-base-dev ffmpeg
sudo pip3 install numpy --upgrade
sudo pip3 install picamera2
cd /tmp
wget https://project-downloads.drogon.net/wiringpi-latest.deb
sudo dpkg -i wiringpi-latest.deb

Then I update the kernel:

sudo rpi-update

And modify:

/boot/config.txt 

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
dtparam=i2c_vc=on
dtparam=i2s=on
dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# Automatically load overlays for detected cameras
camera_auto_detect=0
dtoverlay=camera-mux-4port,cam0-imx477,cam1-imx477


# Automatically load overlays for detected DSI displays
display_auto_detect=1

# Enable DRM VC4 V3D driver
dtoverlay=vc4-kms-v3d
max_framebuffers=2

# Disable compensation for displays with overscan
disable_overscan=1

[cm4]
# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.
otg_mode=1

[all]

[pi4]
# Run as fast as firmware / board allows
arm_boost=1

[all]

When I try to execute

 init_camera.sh
----Test i2c1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:                         -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- 1a -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- 64 -- -- -- -- -- -- -- -- -- -- --
70: 70 -- -- -- -- -- -- --
----Detecting the /dev/video0 device
Can't find video0 device, please check the hardware connection!```
And If i do

libcamera-hello --camera 0

Made X/EGL preview window
[0:05:10.697059953] [1406] INFO Camera camera_manager.cpp:293 libcamera v0.0.1+21-7c855784
[0:05:10.714676058] [1419] ERROR RPI raspberrypi.cpp:1223 Failed to register camera imx477 23-001a: -2
ERROR: *** no cameras available ***```
The hardware connection is correct. Should I modify something in the config.txt file? My kernel version is:

Linux raspberrypi 5.15.74-v7l+ #1595 SMP Wed Oct 26 11:05:08 BST 2022 armv7l GNU/Linux

Side Note: I think this is important:

Side Note: I think this is important:

 sudo cat /sys/kernel/debug/v4l2-async/pending_async_subdevices
imx477 23-001a:
video-mux:
 [fwnode] dev=24-001a, node=/soc/i2c0mux/[email protected]/[email protected]/[email protected]/[email protected]
unicam fe801000.csi:

@rgemas

I asked my colleague @Dion to test it for you and will give you the results in working days.

I am having a similar issue on the raspberry pi with the 64mp camera, is it just a version issue?

It was working fine before I updated my kernel version

Hi,
Please re-install the driver for the camera. We have released the latest driver today.

1 Like

Hi,
I have tested it recently. It works well on my side. The kernel version of the Pi is 5.15.61.
Please re-burn the OS and do not update the kernel. Then give it a try.

1 Like

It works, thanks Dion!