Arducam Multi camera adapter on Jetson Nano

I am trying to set up the ArduCam multi-camera adopter on a Jetson Nano board.
Firstly, when I try to run the commands “ls /dev/v*”, “ls /dev/video*” or “ls /dev/video0”, the device isn’t recognised. I am still following all the instructions provided here Everything works up to the point where I run the python script and I get the following error: execute: 577 No cameras available.

I am only using the build-in cameras IMX219. Before using the multiplexor, I tried two cameras on the two ports on the board and they worked fine.

How can I solve this?
Thank you

Hi @Margarito Lehmann ,

How many cameras have you connected to the multi-camera adapter?

If you don’t have four cameras, you need to make sure there is a camera on port D. For other information, please see Troubleshooting.

I saw that suggestion in a different discussion. I used 4 cameras and still didn’t work.

Can you attach a hardware connection diagram?

Please find attached a picture with the hardware connection. Thank you