ArduCam B0201 on Pi4 regognized as audio out

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)? B0201

  3. What hardware/platform were you working on? Rasp Pi4

  4. Instructions you have followed. (link/manual/etc.)

  5. Problems you were having? The video camera works but the Pi also thinks the camera is an audio output device, thus disabling all other audio output. I need the camera as input and analogue audio output.

  6. The dmesg log from your hardware?

  7. Troubleshooting attempts you’ve made? Rebooted

  8. What help do you need?

This camera only has a single microphone. How can we make it as a analogue audio output??

I understand that the camera only has a microphone, but the Pi4 recognizes it as a USB Audio Output and disables the audio jack. I just plugged in a USB audio out and this will provide audio output but it still shows the USB Camera as an audio output and the headphone jack remains disabled.

From ChatGPT:
To enable the audio jack on Raspberry Pi 4 with a USB camera connected, you can try the following steps:

  1. Check the audio settings:
  • Open the terminal on your Raspberry Pi.
  • Type alsamixer and press Enter.
  • Use the arrow keys to navigate to the USB camera audio output.
  • Press the M key to unmute the audio output if it is muted.
  • Adjust the volume level if needed.
  • Press Esc to exit.
  1. Disable the USB camera audio output:
  • Open the terminal on your Raspberry Pi.
  • Type sudo nano /usr/share/alsa/alsa.conf and press Enter.
  • Scroll down to the section that starts with defaults.ctl.card and defaults.pcm.card.
  • Change the values of defaults.ctl.card and defaults.pcm.card to the number corresponding to the audio jack.
  • Press Ctrl+X, then Y, and Enter to save and exit.
  1. Restart the Raspberry Pi:
  • Type sudo reboot in the terminal and press Enter.
  • After the Raspberry Pi restarts, the audio jack should be enabled.