Arducam 8MP PTZ IMX219DS is not working

I am new to this forum, but I hope to get help here as this is my last resort.
I purchased two cameras Arducam 8MP PTZ IMX219DS and RPI 12MP IMX477R:

I could not make the arducam work and contacted technical support.
They said that using kernel 5.10.92 and should install new 5.15.84. I did this burn the new version on sd card, but the uname -r command still gives 6.1.19-v8+ version. That is completely different number from kernel version. I am confused with OS and kernel numbers. When i tried to run cat /etc/os-release or sudo raspi-config it still does not give the meaningful answer.
Note that second camera RPI 12MP IMX477R is working fine, but i need arducam with adjustable focus for my project.
I am running raspberry pi 4 model B 8 GB using keyboard and mouse.
I am happy to attach the bug report file.
This is the error for command libcam-hello:

libEGL warning: DRI2: failed to authenticate
Made X/EGL preview window
[0:00:57.601499576] [1359] INFO Camera camera_manager.cpp:299 libcamera v0.0.4+22-923f5d70
[0:00:57.643951816] [1372] WARN RPI raspberrypi.cpp:1357 Mismatch between Unicam and CamHelper for embedded data usage!
[0:00:57.645258816] [1372] INFO RPI raspberrypi.cpp:1476 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media3 and ISP device /dev/media1
[0:00:57.646604187] [1359] INFO Camera camera.cpp:1028 configuring streams: (0) 1640x1232-YUV420
[0:00:57.647015094] [1372] INFO RPI raspberrypi.cpp:851 Sensor: /base/soc/i2c0mux/[email protected]/[email protected] - Selected sensor format: 1640x1232-SBGGR10_1X10 - Selected unicam format: 1640x1232-pBAA

Many thanks for your help in advance


Don’t worry, I will do my best to help you.
Don’t think about the kernel version anymore, this will not affect the use.

According to your description, only ptz imx219 can’t work.

Can you just connect the camera board and see if it works?

test command

libcamera-still -t 0

Photo for the point (2)

Photo for the point (1)

Photo for the point (3)

Hello @Edward
Thank you for you reply.
I tried the command that you suggested libcamera-still -t 0 before but it didn’t not work.
Please see the error below that appears after several seconds:

There are several things that i would like to note:

  1. I guess you mean to connect the ptz camera without any additional wires? I disconnected all the wires and tried again but it does not help. Note that location of the socket for the ribbon connection on your photo is different to what i have and what is shown on the arducam website for 8mp ptz camera. Could it be different versions? My camera came preassembled on the board. Sorry that i cannot post more than one photo as new user. Please see my 4th post for socket mount on my camera.
  2. When i did fresh install of the latest OS 5.15 the camera IMX477R worked straight away but when the ptz imx219 was connected the ribbon connection test failed. Please see my 3rd post for the result i got. I used this command i2cdetect -y -r 10 to check so i had to change the config.txt file that system can recognise it at least.
  3. Ptz imx219 camera is recognised correctly after i made the changes in the config file. Please see proof for the command libcamera-hello --list-cameras in my 5th post. I can also change zoom and focus, but no signal from the sensor.

So my feeling is that it’s all to do with the correct settings of the config file. Would it be possible to share the correct setting of the config file for the ptz imx219 camera.

Or are there any additional packages that need to be installed for arducam to work correctly?
I tried following steps as described here
and here
but it does not help

Looking forward to your reply.

Please see my config file below:

For more options and information see

Raspberry Pi Documentation - Configuration

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode


uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border


uncomment to force a console size. By default it will be display’s size minus



uncomment if hdmi display is not detected and composite is being output


uncomment to force a specific HDMI mode (this will force VGA)


uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes


uncomment to increase signal to HDMI, if you have interference, blanking, or

no display


uncomment for composite PAL


#uncomment to overclock the arm. 700 MHz is the default.

Uncomment some or all of these to enable the optional hardware interfaces


Uncomment this to enable infrared communication.


Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)


Automatically load overlays for detected cameras


Automatically load overlays for detected DSI displays


Enable DRM VC4 V3D driver


Disable compensation for displays with overscan



Enable host mode on the 2711 built-in XHCI USB controller.

This line should be removed if the legacy DWC2 controller is required

(e.g. for USB device mode) or if USB support is not required.




Run as fast as firmware / board allows





Please contact me ([email protected]), attach forum link