Arducam 8MP IMX219 not recognising on Nvidia Jetson Nano

Hi, I recently bougth a IMX219 cam for my Nvidia, but I cannot see it on ls /dev/video*, I also cannot see the camera using gstreamer. I attach images of the wiring and mesh info. Should I install any driver or is it plug and play. I attach a dmesg output and some images of wiring. I tried to use it on a raspberry and it also cannot be recognised by raspberry.


It’s a bit strange. From the log you provided, everything seems to be normal. The camera has been detected and bound normally.
Can you try to change the camera interface?

I have tried changing de port and still not working, should I send you another mesh?

Maybe we can conduct a remote support to diagnose the problem,
We generally use teamviewer, you can install teamviewer on your PC and use ssh to connect to Jetson?
Do you think this is ok?

Sorry for the late reply, we have bought another IMX219 camera, and still not working so we suppose it isn’t a hardware problem. Sure I can let you use the Jetson via TeamViewer and ssh, the only problem is the timezone, I live in Spain (GMT+1) and I cannot always be in my office, so I am not sure if I can be checking the Teamviewer while you use the Jetson. However, I could let it working and you connect whenever you can. So what you prefer to do?

The best way is to find a suitable time, we are all in the office.
If this is difficult to achieve, then you can try to keep teamviewer open (but I am a little worried about security issues)
Our time zone is UTC+8 (Beijing time), under normal circumstances we can carry out remote support between 9:00~11:00 in the morning and 14:00~17:00 in the afternoon.

Okay, I think I can be in the office at 9:00 UTC+8. What day do you prefer to carry out the remote support?

I have just make it work, I dont now exactly what was hapenning, just install Nvidia Jetpack 4.6.

Thanks for the help!

That’s great news, glad to hear it’s working!