Arducam 64MP installation issue

  1. Where did you get the camera module(s)?

[Order #83804]

  1. Model number of the product(s)?

  2. What hardware/platform were you working on?
    Raspberry Pi 3B+ V1.3

  3. Instructions you have followed. (link/manual/etc.)
    How to use arducam_64mp & arducam_64mp FAQ - #2 by Edward
    and the quick start guide from the mail I got. (as a new user I can only put two links into this post.)

  4. Problems you were having?
    Camera is not being detected / working

  5. The dmesg log from your hardware? - Locked Paste
    Password is: arducam

  6. Troubleshooting attempts you’ve made?
    Followed the guides, checked the cabling.
    ls /dev/video shows
    ls /dev/video*
    /dev/video10 /dev/video12 /dev/video14 /dev/video16
    /dev/video11 /dev/video13 /dev/video15 /dev/video18

  7. What help do you need?
    Need to get the camera working
    No cameras available


I don’t see any information about the camera in dmesg.

I need more information.

cat /boot/config.txt
dmesg | grep libcamera
dmesg | grep arducam
# For more options and information see
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border

# uncomment to force a console size. By default it will be display's size minus
# overscan.

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

# uncomment for composite PAL

#uncomment to overclock the arm. 700 MHz is the default.

# Uncomment some or all of these to enable the optional hardware interfaces

# Uncomment this to enable the lirc-rpi module

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)


I also tried with


instead of the dtoverlay line written above

dmesg | grep libcamera and
dmesg | grep arducam come up empty


Have you complied with the following commands?

if you complied commands:
both is need


I did all of that already. Drivers are instelld, both applications as well. Been playing around with the config.txt. I had both in there → just reinserted both lines, still no camera being detected.
I just ran the commands again, the driver install added the
dtoverlay=arducam-64mp again. No luck.


You can contact my email([email protected]).
I can help you solve problems remotely.

So i switched out the cable, had a working camera for about 5 minutes while I was trying to get a higher resolution than 1920x1080
Now “no cameras available” again…
I got no idea what is going on here.

dmesg | grep arducam
[ 0.098604] platform 3f801000.csi: Fixed dependency cycle(s) with /soc/i2c0mux/[email protected]/[email protected]
[ 14.306458] arducam_64mp 10-001a: failed to read chip id 4136, with error -5
[ 14.315629] arducam_64mp: probe of 10-001a failed with error -5


Don’t worry, you can contact me to see if there is a problem with the hardware.