Arducam 64MP camera in failed to allocate buffers, failed to start camera

This is a brand new freshly imaged SD card with the latest available 64-bit Raspberry PI OS. In fact, I’ve tried to reimage it twice already with the same results and error(failed to allocate buffers, failed to start camera)
The only installation of additional software and drivers was related to Arducam 64mp camera. I’m able to have output specifying 4624x3472 16mp image, attempting to save a full res 9152x6944 64mp file throws that error. Searching the forums it sees I’m not the only one having this issue.

As of right now, the camera isn’t operational and I would like to get this product working. Any additional suggestions on things I can try?

1 Like


There will indeed be users who will try all the solutions and still not be able to use them.

I’m still looking for some possibilities. You can try the lite version (without interface), and the lite version is found to be more stable.


I’m working on project in not possible without interface (lite version os).
I have a 50 arducam 64mp camera, some camera properly work some camera in error failed to buffers. any setting parameter change or update??


Do you need qt for your project?

I think it’s just a phenomenon, it might be that the buffer is hitting borderline values, sometimes enough, sometimes not enough.

yes, I need ‘qt’ for my project. My project is every interval time high-quality capture and sent to the server image, sometimes not capture the image and error fails to buffer then the project is stopped so any suggestions.


Currently we don’t have a more perfect solution, and we are actively seeking it.

All updates will be reflected in the doc.

1 Like

for your newer Arducam 64 troubleshooting, it says to use OS Lite for reliable 64MP photos.

I was able to take photos with libcamera still, but when i tried libcamera-raw it still has the *** failed to allocate capture buffers error***


Try a parameter “–buffer-count 1

Ok cool, adding --buffer-count 1 made the command run, however, if i set it to take a full resolution image, the command goes through, and there aren’t any errors that come up, but it doesn’t produce a file

for instance running this command
libcamera-raw -t 1000 -n -o ntest64mp%05d.raw --segment 1 --buffer-count 1 --width 9152 --height 6944

but if i run a regular command with no specified height or width

libcamera-raw -t 1000 -n -o ntest64mp%05d.raw --segment 1 --buffer-count 1

it runs fine, but it produces a 1280x720 image

By the way, for other people who may have been confused like I was when trying to deal with trying to capture raw images

libcamera-still -r

is the command to capture a RAW photo (and it will give you a file in the …dng format that you can use rawtherapee to view and convert)

sudo apt install rawtherapee


libcamera-raw (on the other hand) is for capturing raw VIDEO files

which do save, but i cannot capture 64MP images with libcamera-raw (only 1280x720 image )

but if you want to capture a single RAW image this command works:

libcamera-still -t 5000 -n -o test64mp.png --width 9152 --height 6944 -r

which will save both a png file (about 10MB) and a .dng file (about 120MB)


Try this

libcamera-raw -t 10000 -n -o ntest64mp%05d.raw --segment 1 --buffer-count 1 --width 9152 --height 6944

ahhhh ok, i see, i was just not using the libcamera-raw for a long enough time, thanks!

1 Like