Arducam 16mpx problem

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Raspberry pi 3
4.Which instruction are you following?
5.Has your product ever worked properly?
it never worked
6.What problems are you experiencing?
Ahoj, řeším problém s arducam 16mpx z automatické expozice, vyvážení bílé a autofokusu … Když zadám příkaz: ./arducamstill -t 5000 -m 1-ae 1 -awb 1 -e jpg -o test.jpg tak se nic nestane expozice a ostatní parametry se nemění :frowning: Mohl by mi někdo pomoci?
7.What attempts at troubleshooting have you already made?

8.How would you like us to help you?


I am having issues with IMX298 module ( purchased from local reseller: )

Following the manuals I have successfully compiled the SDK from

for RPI3 B+ and RPI Zero. In case of both RPI models the gpu_mem is set to high value above 256MB but when selecting resolution mode 3 and 4 (width: 4656, height: 3496) for arducamstill I am getting memory allocation error:

Open camera... Found sensor imx298 at address 1A mode: 0, width: 1160, height: 800, pixelformat: pBAA, desc: 4x4 binning 60fps mode: 1, width: 1920, height: 1080, pixelformat: pBAA, desc: 60fps mode: 2, width: 2336, height: 1748, pixelformat: pBAA, desc: 2x2 binning 27fps mode: 3, width: 4656, height: 3496, pixelformat: pBAA, desc: 8fps mode: 4, width: 4656, height: 3496, pixelformat: pBAA, desc: 12fps index: 0, CID: 0x00980914, desc: V4L2_CID_HFLIP, min: 0, max: 1, default: 0, current: 1 index: 1, CID: 0x00980915, desc: V4L2_CID_VFLIP, min: 0, max: 1, default: 0, current: 1 index: 2, CID: 0x00980911, desc: V4L2_CID_EXPOSURE, min: 0, max: 65535, default: 1660, current: 1608 index: 3, CID: 0x009A090A, desc: V4L2_CID_FOCUS_ABSOLUTE, min: 0, max: 1023, default: 150, current: 0 usrvcsm: [vcsm_malloc_cache]: [1230] [mmal_vc_port buffer]: ioctl mem-alloc FAILED [-1] (hdl: 0) usrvcsm: [vcsm_vc_hdl_from_hdl]: [1230]: invalid device or handle! usrvcsm: [vcsm_lock]: [1230]: invalid device or invalid handle! mmal: manually_port_pool_create: could not allocate 20407296 bytes of shared memory (handle 0) mmal: Failed to create connection. mmal: Failed to create pool mmal: Failed to enable camera set resolution status = 1
Selecting lower resolutions, gives me an image with green tint:


Geen tint

Any help would be appreciated.

Best Regards,