AR0234 Hardware XVS Trigger Problem

I am currently having issues with the trigger feature on AR0234 cameras. This seems to be a hardware related problem. I also contacted the support via the contact form.
(I don’t know if there is only the support team that answers to the posts on the forum so I try here too, maybe someone has the answers I am looking for)

1. Where did you get the camera module(s)? 


2. Model number of the product(s). 

AR0234 / UC788 Rev.B

3. What hardware/platform were you working on? 

Raspberry PI5

4. Instructions you have followed. (link/manual/etc.) 

I followed the « quick start guide » and the « external trigger guide »

5. Problems you were having. 

I’m currently having issues with the XVS Pin on 5 cameras out of 13 (maybe more now)

A quick explanation on how the system works :

  • I use a PI to send a trigger signal to 2 level-shifters (16 channels). Level shifters convert my 3.3V signal into a 1.8V signal.
  • These signals are sent into a serial cable (DB15). I have to setup resistors at both sides of the cable to ensure that enough current is drawn through this cable.
  • The system is composed of 4 turrets (2x3 cameras and 2x1 camera) and all cameras are synchronized.

The problem is the following : despite an identical hardware on every turrets, one of the 3 camera turret is not working at all. Since I can swap the cameras from one turret to another, I tried to use each camera on each turret, and it seems that the problem is not coming from the system I’ve made.

6. The dmesg log from your hardware. 

No dmesg, it is a hardware related problem and I don’t know if I can get any log related to the trigger signal on the hardware.

7. Troubleshooting attempts you’ve made. 

When I noticed that one turret was not working correctly, I tried to solder again stuffs that are linked to the camera by a wire, but I did not touched the cameras. I don’t understand how could I break 3 cameras at once while only soldering a connector. The connector and the cameras are separated by a 40 centimeter long wire.

I couldn’t find any damaged or burnt components or tracks.

What I also noticed, is a continuity between XVS and GND pins on cameras that don’t work (around 1200 ohms) which I cannot find on cameras that work.

Also, cameras that don’t work with the system are working nicely when I use a low frequency generator instead of the trigger system (with no resistor). Also, it stops working as soon as I add a resistor to ensure enough current is drawn.

I have the feeling that this problem occurs when too much current is drawn and generates a short circuit from XVS to GND. That would probably explain why it doesn’t work when I add resistors, while it works when there is none.

I have tried to take account of this hypothesis and this would mean, due to this short-circuit, that my wiring looks like a voltage divider. Unfortunately, it would require me to get a factor of 1 for this voltage divider because the voltage coming from the wire is already 1.8V. I also tried the calculus for a desired voltage of 1.6V (enough to trigger) instead of 1.8V. That would require me to use 3 ohms resistors, which won’t be resistive enough to draw current from the level-shifter through my cable and doesn’t works.

8. What help do you need? 

I just need some help to understand where this problem could come from, because right now I cannot use anymore those cameras on my system.
Can it be a current leakage ? And from where ? Can it come from my welds ?

Thanks for your help,

Hi Valentin,
Give us some time to check your problem, I’ll reply you in two days.
Thank you for your patience.