64mp camera install issues

Although I bought the 64mp camera pre-sale, I’ve only just tried to install it, and I’m unable to get it recognised.

I’ve followed the instructions from this forum and tried it on both a 3A+ and a Pi4. I get the same results.

In my dmsg - I think the relevant sections are:

.986679] imx519 10-001a: chip id mismatch: 519!=682
[ 9.015363] imx519: probe of 10-001a failed with error -5
.
.
.

[ 6.135175] i2c i2c-10: Failed to register i2c client dw9807-vcm at 0x0c (-16)
[ 6.135199] i2c i2c-10: of_i2c: Failure registering /soc/i2c0mux/[email protected]/[email protected]
[ 6.135251] i2c i2c-10: Failed to create I2C device for /soc/i2c0mux/[email protected]/[email protected]
[ 6.135332] i2c i2c-10: Failed to register i2c client 64mp at 0x1a (-16)
[ 6.135351] i2c i2c-10: of_i2c: Failure registering /soc/i2c0mux/[email protected]/[email protected]
[ 6.135397] i2c i2c-10: Failed to create I2C device for /soc/i2c0mux/[email protected]/[email protected]

config.txt - shortened

# Automatically load overlays for detected cameras
camera_auto_detect=1

# Automatically load overlays for detected DSI displays
display_auto_detect=1

# Enable DRM VC4 V3D driver
dtoverlay=vc4-kms-v3d
max_framebuffers=2

# Disable compensation for displays with overscan
disable_overscan=1

[cm4]
# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.
otg_mode=1

[all]
arm_boost=1
dtoverlay=vc4-kms-v3d,cma-512

[pi4]
# Run as fast as firmware / board allows

[all]
dtoverlay=arducam_64mp
dtoverlay=imx519

I’ve just tested the HQ on the Pi4 and that works OK.

Any suggestions?

Mike

Blockquote

Hi,
I think the link below would assist you in installing the camera driver.

https://docs.arducam.com/Raspberry-Pi-Camera/Native-camera/Quick-Start-Guide/#imx519hawkeye-64mp-cameras