1MP Quadrascopic Camera (SKU267 ) on Bulleyes 6.1.21

2 years ago I purshased the SKU267 kit and tested it on Buster OS and worked as expected.
Now, Itried to use the new documentation of the Multi-Camera-CamArray for Bulleyes (section Raspberry Pi Bullseye OS 6.1.21 and Later/Bookworm OS) but I facing some issues.
(install libcamera and change config.txt)

  • camera is detected according to dsmeg output
  • v4l2-ctl -d /dev/video0 -l returns empty output
  • v4l2-ctl -d /dev/v4l-subdev0 -l returns expected controls
  • I can get/change some of the controle using -c/-C
  • libcamera-hello --list-cameras returns No cameras available!
  • if I add media-controller=0, v4l2-ctl -d /dev/video0 hangs indefinitely

My questions are:

  • Does this kit still supported by Arducam?
  • Is there a frimeware update for this kit?
  • what I am missing except install libcam and modify the config.txt


Can you post a picture of this KIT? If it worked on Buster OS, I think it uses the old hardware/firmware, so it is not supportive of Bullseye/Bookworm OS and cannot update the firmware.

Thanks Dion for your reply.

Would you please confirm if there is a need for a firmware update?