0V9281 don't work on CM4

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Raspberry CM4
4.Which instruction are you following?
5.Has your product ever worked properly?
works on Raspberry pi 4B
6.What problems are you experiencing?

I bought a arducam 0v9281, it works fine on Raspi 4B, but our project need to move it on to CM4, it doesn’t work.

dmesg says:

ov9281 10-0000: unexpected sensor id(267c1400), ret -5

preview-camera0 gives:

init camera status =4100;

camera_i2c gives:

Setting GPIO for board revision:b03140

Failed: don’t know how to set GPIO for this board.

7.What attempts at troubleshooting have you already made?
see above
8.How would you like us to help you?
replay post, email, phone

I will test our OV9281 on cm4 and reply you as soon as possible.


I connected arduCam on cam1 with FPC. I understand I need to control power pin (IO5 on official doc, but it is not on IO board schematic).

I also followed official doc putting a dts-blob.bin in /boot folder.The raspi official camera also works on IO board. So I believe wiring should be OK.


Hi Bin,

Any news?


Sorry for my late reply, My hardware is defective and I need to buy a new one.

Hello, I have add support for CM4 platform, Please download our new library and use arducamstill to test your ov9281 on CM4

Hi Bin,

I downloaded git again, but arducamstill gives :

Open camera…

Found sensor ov9281 at address 60

init camera status =4100

camera_i2c still gives

setting GPIO for board revision b03140

failed:don’t know how to set gpio for this board


please help.


Don’t worry, Please try to use this libarducam_mipicamera.so file I attached for you.

Notice unzip the file then copy the libarudcam_mipicamera.so to MIPI_Camera/RPI/lib path to replace the old version lib.

then install it using make install command.


Hi Bin,
It’s still not working. Here is what I did:

  1. I use old git commit on Dec 23, replace the lib.so file with in your attachment , then run ./arducamstill -t 0 -m 1 -awb 1 -ae 1

it gives some output like this (I didn’t took snapshot at that time so I crop a pic in forum):

then it freeze, no preview, no Frame rate. And it cannot close by ctrl+c ,I have to kill it by kill command.

2.Then I pull your new git commit on Dec 24, and use lib.so in attachment. run

./arducamstill -t 0 -m 1 -awb 1 -ae 1

it gives:

then freeze. As you can see ctrl +c can not stop it, need kill command to stop it.

Please help.


We are going to use OV2311 on CM4 too. Is it supported by now? Will it work if I connected it to cam1?


Yes, we have added support for CM4, Please use ./arducamstill -t 0 -cs 1 to run the second camera.

Feel free to let me know if you need more help.



Just to be clear: did you mean OV2311 worked on CM4? We use single camera setup.

Thank you.

Yes. Of course. Feel free to let me know if you need more help.


Is it possible for you to actually test mode 6 capture and mode 0 yuv callback on CM4? Our CM4 (with WIFI) isn’t coming until end of Jan. Given how Pi 4B did not work consistently with arducam across revisions, it would be great if there were some assurance before we got the hardware.

(with OV2311 that is)


It should be OK. Don’t worry and I will try my best to help you.


Confirmed: OV2311 + CM4 revision b03140 works.

Thank you for the great work!

You are welcome.


how i get updated libarducam_mipicamera.so file?