Using Pivariety IMX298 (SKU B0323) with Nano

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)?
    SKU B0323

  3. What hardware/platform were you working on?
    Jetson Nano 2GB

  4. Instructions you have followed. (link/manual/etc.)
    installed driver automatically for my kernel version, in particular I ran
    ./ -m arducam
    and it installed properly:
    Preparing to unpack arducam-nvidia-l4t-kernel-t210-4.9.253-tegra-32.6.1-20210915100958_arm64.deb …
    Unpacking arducam-nvidia-l4t-kernel (4.9.253-tegra-32.6.1-20210915100958) …
    Setting up arducam-nvidia-l4t-kernel (4.9.253-tegra-32.6.1-20210915100958)

  5. Problems you were having?
    image is dark and greenish; can’t change any values in the module using v4l2-ctl (the changes are not given effect)

  6. The dmesg log from your hardware?
    [ 0.212135] DTS File Name: /var/jenkins_home/workspace/n_nano_kernel_l4t-32.6.1-arducam/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t210/batuu/kernel-dts/tegra210-p3448-0003-p3542-0000.dts

[ 0.408333] DTS File Name: /var/jenkins_home/workspace/n_nano_kernel_l4t-32.6.1-arducam/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t210/batuu/kernel-dts/tegra210-p3448-0003-p3542-0000.dts

[ 1.302899] arducam-csi2 6-000c: firmware version: 65537

[ 1.303255] arducam-csi2 6-000c: Sensor ID: 0x0298

[ 1.387081] arducam-csi2 6-000c: sensor arducam-csi2 6-000c registered

[ 1.553500] vi subdev arducam-csi2 6-000c bound

  1. Troubleshooting attempts you’ve made?
    removed/reinstalled kernel driver; a regular Pi v2 camera works fine, and my Arducam IMX298 works fine on my Raspberry Pi 4

  2. What help do you need?
    I would like to know whether the SKU B0323 camera works on the Jetson Nano or do I need to buy a different camera. It appears that the white balance and exposure are not set properly when using the camera on the Nano, and the v4l2-ctl commands to change the values do not work. For example, if I run:
    v4l2-ctl -C exposure

I get:
exposure: 1600

but if I run:
v4l2-ctl -c exposure=3200
it does not change the exposure, which remains at 1600. The same is true for other parameters. So I can’t set it to autofocus or auto white balance, etc.

I’ve read a few cryptic comments about the Pivariety cameras, but I thought I would ask directly whether it is possible to use this camera (which is called Pivariety Motorized Focus Camera Module for Raspberry Pi) with the Jetson Nano 2GB.

Thanks for your thoughts.

Hi @hal

B0323 is used on Jetson without ISP support, so it appears green.
Regarding the v4l2 control issue, this is because the Jetson driver has not updated the v4l2 control range correctly, which will be updated in the future.

In that case, would you recommend an equivalent model of Arducam that would work with the Jetson Nano and gives the correct colors (also that can be used with OpenCV)?

Thanks for your quick response.

Currently there are IMX219 and IMX477 supported by ISP on Jetson,
And it needs to use gstreamer pipeline, please refer to CSI-Camera for details