Trying to capture from camarray uninterruptibly blocks the shell

I have a Camarray with 4 OV9782 cameras that I’m trying to use on a Raspberry Pi 4. I’ve installed the latest version of raspbian (Bullseye, kernel 5.15.61, 64bits, no desktop environment) and the driver for the Camarray using the instructions from this page and tried to capture an image using libcamera-still (with the -n option to prevent preview since I’m working headlessly) and the example code from the given repository.

Sadly, whenever I try to capture using either one of those methods, the program blocks and nothing short of rebooting the Raspberry Pi solves this. I’ve tried Ctrl+C, killing the process from another ssh session but everytime I do, the original shell stays unresponsive and using ps just shows the process in Zombie state. I get this message right before the process blocks but it doesn’t seem to display any valuable info (not to me at least):

Anyone has an idea on how to solve this ?


Can you disclose your code and the sku number of the camera?

I used the code from the git given in the “picamera2 with arducam” tutorial (GitHub - raspberrypi/picamera2: New libcamera based python library) and the command “libcamera-still -n” (no preview since I’m working headlessly)

The camarray is a UC-512 Rev.D1 and the cameras are UC-760 Rev.A


Are you convenient to give me your code to test it, I will test it in the no display state.

I used the “” program from the git repository I mentioned in my previous post


Just make sure you modify it or not, I’ll test it today.

I made no modif to the python program

Just tried on the version of Bullseye that is linked to in the tutorial page and I get the same problem. I will try to use a version with a kernel explicitly supported as well as another Raspi. Will keep you posted

I’ve tried installing a version of RaspiOS that uses kernel 5.4.51-v7l+ since it is one of the explicitly supported kernel version but now the driver won’t even install under the excuse that I’m using an “unsupported kernel version”


The Buster system does not work with picamera2 and our documentation currently has a few pages that need to be updated. I’m working on a brand new doc that will correct all the current errors. Stay tuned.So please use Bullseye.

I tested the no-display environment.There is no blockage occurring.
Now I want you to try it again using bullseye. Give me the full dmesg logs after the blocking occurs.

I booted my original system again (Bullseye, 5.15.61, 64bits, no DE). Here’s what my dmesg reads

The complete dmesg output has the following messages interpolated


It is i2c unstable.
You can contact me at [email protected] , please include the forum link again.