The Instructions to install the necessary scripts and drivers don't work

  1. Where did you get the camera module(s)?
  • Amazon
  1. Model number of the product(s)?
  • It has to be the PDAF&CDAF (honestly, I can’t find any information on any platfrom that is 100% verifiable on the Model No.
  1. What hardware/platform were you working on?
  • Raspberry Pi 4 B 4GB with the montioned camera module.
  1. Instructions you have followed. (link/manual/etc.)
  • This link is to the “Quick Start” for this specific camera module: click here to see
  1. Problems you were having?
  • The Camera Module is not detected at all. I double-checked the connections, flashed a new MicroSD with Raspbian and followed the instructions. There was that one blog post from back in '22 (not too long ago but still) that gave instructions on how to bypass the issue with the directories but that didn’t work
  1. The dmesg log from your hardware?
  • It tells me, "./ line 7: syntax error near unexpected token ‘newline’
    ./ line 7: ‘’
    (I’m sorry if this is incorrect, I am typing this up on a different machine.)
  1. Troubleshooting attempts you’ve made?
  • I have tried all the workarounds that I have been able to find on the internet, but there are not that many.
  1. What help do you need?
  • I would like to know if there is a more current and up-to-date list of instructions in order to get the Arducam 16MP Camera Module working with a Raspberry Pi 4 B

Okay, so I started over with the linked instructions, but this time I made sure to use sudo after running the first command (step 1).
As for steps 2-4, they all installed perfectly, which is surprising.
After the reboot, the RPi tries to run the “libcamera-still -t 5000” command, which pops up a quick window but then it goes away and the command fails stating “INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3139-5baab39e
terminate called without an active exception
I have no clue what to do at this point. I will continue to troubleshoot, I love open-source projects, and I am finally getting to a point of understanding where if possible, I would be honored to help out as much as I possibly can. That’s the whole reason I signed up for the blog in the first place.
If anyone has any guidance or suggestions to turn me in the right direction, thank you in advance. I would love to hear feedback regardless of the topic/suggestion.

Thanks again.


Before, I need some information

Please reboot your device and execute the following command:

wget -O arducam-camera-bug-report
chmod +x ./arducam-camera-bug-report

This will output an arducam-bug-report.txt in the current directory.

Please send this file to me via google cloud disk or similar platform or email ([email protected])

And if possible, please send me the hardware connection diagram.

Thank you for your cooperation and have a nice life.

Okay, I have done what you requested, but I cannot figure out a decent way to make the hardware diagram. As of right now for testing purposes, it is just a Raspberry Pi 4 B with the Arducam 16MP Module connected to the Camera Port with a CSI cable.

Here is the arducam-camera-bug-report.txt


I received my script, but it appears to be the original file instead of the output file. Could you please take a closer look and make sure to send me the correct file?

Yes, let me check it again. Okay, I found the problem. There was an issue when I run the command “./arducam-camera-bug-report”. It returns with a Permission Denied, so when I try to run “sudo ./arducam-camera-bug-report” it returns “sudo: ./arducam-camera-bug-report: command not found”.


I hope you can delete all related files and go through the process again.

wget -O arducam-camera-bug-report
chmod +x ./arducam-camera-bug-report
sudo ./arducam-camera-bug-report

My bad, I see what I did wrong, I kept selecting the base file.

Here is the output text file after getting the script to run correctly. Link

I accidentally chose the script file because I thought that I had to rename it as a .txt file but that was not the case. My apologizes.

It may be helpful to others to know that after running the script, the text file that gets output is named “arducam-bug-report.txt”, and not “arducam-camera-bug-report.txt”

I appreciate you trying to help. That is a good show of character, and I believe that you’re truly a stand-up guy.


J. P.

I’m going to cut my losses and return the Camera Module because it does not work with the updated firmware and current Operating Systems at least for the Raspberry Pi OS. I went through the bug report myself, and I don’t think it is capable of connecting with the module. Thanks again for the help, Edward!


The current release of the Raspberry Pi system with the new Bullseye system may confuse you, but it is precisely because of this system change that it makes everything better. If you’re interested, you can try it again on the latest bullseye system.

Your camera tutorial link:
You may be reading the wrong tutorial.

1 Like

So I started over from the very beginning. I reflashed a Micro SD with Raspberry Pi OS. I booted it up and ran sudo apt update && upgrade
Then I began following the tutorial from the last link you sent me above, but this time, instead of typing the commands I just ssh’d into the RPi and copied and pasted every single command and they all worked this time.


It seems that after changing the system, everything becomes very easy. Great to hear that information.