Stereo Arducam (OV9281) not working on Jetson Nano: VIDIOC_DQBUF: Resource temporarily unavailable

  1. Where did you get the camera module(s)?
    Uctronic

  2. Model number of the product(s)?
    B0337

  3. What hardware/platform were you working on?
    Jetson Nano (Jetpack 32.6)

  4. Instructions you have followed. (link/manual/etc.)
    Camarray – Arducam 1MP*2 Stereo Camera MIPI Module - Arducam

  5. Problems you were having?
    Everything worked until I tried to execute the python example script with:
    python3 arducam_displayer.py -f GREY --width 2560 --height 800 -d 0 --fps

  6. The dmesg log from your hardware?
    [ 0.212156] DTS File Name: /var/jenkins_home/workspace/n_nano_kernel_l4t-32.7.1-arducam/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t210/porg/kernel-dts/tegra210-p3448-0000-p3449-0000-b00.dts
    [ 0.420610] DTS File Name: /var/jenkins_home/workspace/n_nano_kernel_l4t-32.7.1-arducam/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t210/porg/kernel-dts/tegra210-p3448-0000-p3449-0000-b00.dts
    [ 1.324145] arducam-csi2: arducam_read: Reading register 0x103 failed
    [ 1.324149] arducam-csi2 7-000c: probe failed
    [ 1.324177] arducam-csi2 7-000c: Failed to setup board.
    [ 1.348289] arducam-csi2 8-000c: firmware version: 0x0003
    [ 1.348651] arducam-csi2 8-000c: Sensor ID: 0x0000
    [ 1.400388] arducam-csi2 8-000c: sensor arducam-csi2 8-000c registered
    [ 1.562638] vi 54080000.vi: subdev arducam-csi2 8-000c bound
    [email protected]:~/MIPI_Camera/Jetson/Jetvariety/example$ python3 arducam_displayer.py -d 0
    Firmware Version: 3
    Sensor ID: 0x9281
    Serial Number: 0xADA4B931
    select timeout
    VIDIOC_DQBUF: Resource temporarily unavailable
    Traceback (most recent call last):
    File “[arducam_displayer.py]”, line 121, in
    display(cap, arducam_utils, args.fps)
    File “[arducam_displayer.py]”, line 31, in display
    frame = frame.reshape(int(h), int(w))
    AttributeError: ‘NoneType’ object has no attribute ‘reshape’

  7. Troubleshooting attempts you’ve made?
    I’ve checked that the connectors are plugged in correctly.

  8. What help do you need?
    I would be very grateful for some help on how to get the arducam_displayer.py script running.

The camera has been detected and the driver installed without problems.
Can you provide a photo of the cable connection? It could be a cable problem, or a damaged camera.

Hi Wong, thanks for your reply.


Here’s a photo of the cable connection.
The red light is on and a green light blinks a few times when the Jetson is turned on.

Thank you very much, this is very useful information,
Does the green LED blink when you execute the program?
If it doesn’t flash, then the mod is broken.

Unfortunately it doesn’t flash.

Then it looks like the module is damaged, you can contact [email protected] for replacement.

Hi Wong,
thanks for your help. Actually I was wrong, the green LED doesn’t flash when it’s turned on.

I have another arducam, B0266: Arducam 1MP*2 Stereoscopic Camera Bundle Kit for Raspberry Pi, Nvidia Jetson Nano/Xavier NX, Two OV9281 Global Shutter Monochrome Camera Modules and Camarray Stereo Camera HAT - Arducam

When I power the HAT module, the green LED flashes three times. I connected it to Jetson Xavier NX with Jetpack 32.5 installed. I installed the driver, but the camera is not detected (when executing ls /dev/video0).
This is the dmesg output:
[ 0.445190] DTS File Name: /var/jenkins_home/workspace/ier_nx_kernel_l4t-32.5.2-arducam/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t19x/jakku/kernel-dts/tegra194-p3668-all-p3509-0000-arducam.dts
[ 0.720788] DTS File Name: /var/jenkins_home/workspace/ier_nx_kernel_l4t-32.5.2-arducam/kernel/kernel-4.9/arch/arm64/boot/dts/…/…/…/…/…/…/hardware/nvidia/platform/t19x/jakku/kernel-dts/tegra194-p3668-all-p3509-0000-arducam.dts
[ 2.047331] arducam-csi2: arducam_read: Reading register 0x103 failed
[ 2.047507] arducam-csi2 9-000c: probe failed
[ 2.047649] arducam-csi2 9-000c: Failed to setup board.
[ 2.071747] arducam-csi2: arducam_read: Reading register 0x103 failed
[ 2.071900] arducam-csi2 10-000c: probe failed
[ 2.072030] arducam-csi2 10-000c: Failed to setup board.

It looks like the cables on the Jetson Xavier NX side are reversed.
image


The side of the cable shown in the photo is plugged into the CSI slot facing towards the Jetson Nano.
This is the dmesg output on Jetson Nano:

[ 1.746427] arducam-csi2: arducam_read: Reading register 0x103 failed
[ 1.752917] arducam-csi2 7-000c: probe failed
[ 1.757314] arducam-csi2 7-000c: Failed to setup board.
[ 1.787038] arducam-csi2: arducam_read: Reading register 0x103 failed
[ 1.793505] arducam-csi2 8-000c: probe failed
[ 1.797897] arducam-csi2 8-000c: Failed to setup board.

This cable connection method is correct,

Can you take a picture of the back side of the HAT? I need it to confirm the problem.
Also can you execute i2cdetect -r -y 9 and i2cdetect -r -y 10 and send me the results?
(Jetson Nano is 7 and 8, JetsonXavier is 9 and 10)

Hi Wong,
I was actually able to solve the problem by reversing the cable on the HAT side. Now I can succesfully run the python example program.

I didn’t even notice it, I confirmed there was a problem with the cable, but I thought it was the Jetson part of the cable that was wrong. .
Anyway, glad it works.