SPI interface Error

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
?? SKU: B0068 - Arducam Mini Module Camera Shield 5MP Plus OV5642 Camera Module for Arduino UNO Mega2560 Board & Raspberry Pi Pico
3.Which Platform are you using the product(s) on?
Arduino Nano 33 BLE, or Arduino UNO, or B-L072Z-LRWAN1 (STM32L072CZ)
4.Which instruction are you following?
online documentation https://github.com/ArduCAM/Arduino
5.Has your product ever worked properly?
never worked
6.What problems are you experiencing?
With capture to SD-card, the initialization logic for the SPI (expecting 0x55) doesn’t succeed, and just repeatedly issues the message “SPI interface Error” on the serial monitor.

Removing the SD-Card and using ArduCAM_Mini_5MP_OV5642_Plus_Functions the mesages are “ACK CMD SPI interface Error! END”.

The unit I was shipped does not match any of the model pictures in the documentation, e.g. the listing on the Arducam product page, or the camera models page. See image attached. (note, there are no components between the camera housing and the Winbond chip)

unknown ArduCAM model

Was I shipped an imitation/knock-off? Should I complain to UCTRONICS?

If not, what settings should be used in memorysaver.h for this unit?
I’ve assumed #define OV5642_MINI_5MP_PLUS with no shield, but documentation around model choice is fairly minimal, given this model is not mentioned on the web site.

If the choice of memorysaver.h setting is correct, what are my next steps to determine what the problem is?
7.What attempts at troubleshooting have you already made?
Built and tried the same circuit with three different Arduinos, parts, and breadboard wiring. Tried various chip select options. Tried without SD-Card using functions test.
8.How would you like us to help you?
Confirm this is a valid product. Identify memorysaver.h #define required. Suggest debugging next steps.

Arducam product page: https://www.arducam.com/product/arducam-5mp-plus-spi-cam-arduino-ov5642/

camera models page: https://www.arducam.com/docs/spi-cameras-for-arduino/camera-models/



You don’t seem to find the correct operation tutorial, you can refer to the link below to test.
Please don’t worry about product quality issues, we will try our best to help you.


I am seeing the same symptom in almost the same situation. I bought the same camera from UCTRONICS but I am trying to interface it to an Arduino Mega2560. I am using ArduCAM_Mimi_5MP_OV5642_Plus_Functions, though I had to change the serial speed in the not SAM3X8E case from 921600 to 115200 to get the serial monitor to work. I get the same error message: ACK CMD SPI interface Error! END. I added a println of temp after the error and it prints 0.

I am using an unmodified memorysaver.h, since it appears to be set correctly: only OV5642_MINI_5MP_PLUS is defined.

I believe I have wired the camera correctly using the provided 8-wire cable: camera pin 1 to Arduino digital pin 7; camera pins 2, 3 and 4 to Arduino digital pins 11, 12 and 13; camera pin 5 to ground; camera pin 6 to 5 volts; camera pin 7 to SDA1 and camera pin 8 to SCL 1.

I have tried the camera both with and without an Ethernet + mini SD shield.

I would like you to help me by explaining what I have done wrong, so I can fix it. The most obvious possibility is that I have wired the SPI incorrectly; perhaps I need to do something special to tell the library that camera pins 2, 3 and 4 are wired to Arduino digital pins 11, 12 and 13.


You can try the wiring method in this link, if the problem still exists, we will continue to discuss.


Thank you for the wiring reference. I was unable to follow your advice directly since I do not have the female connectors needed for the male ICSP pins. However, I learned that these signals are duplicated elsewhere on the board.

I connected Arducam pin CS to Arduino digital pin 7, Arducam pin MOSI to Adduino pin 51, Arducam pin MISO to Arduino pin 50, Arducam pin SCK to Arduino pin 52, Arducam pin GND to the Arduino GND pin next to pin 51, Arducam pin VCC to the Arducam 5 volt pin next to the 3.3 volt pin, Arducam pin SDA to Arduino pin 20 and Arducam pin SCL to Arduino pin 21.

I now get the following messages on the serial port: “ACK CMD ArduCAM Start! END / ACK CMD SPI interface OK. END / ACK CMD OV5642 detected. END”. In addition, the heat sink on the back of the camera has gotten a little warm, so I believe the camera is now working. My next challenge will be getting data to the program through the serial port.

I hope this information wil be useful to other ArduCam users with an Arduino Mega 2560.