Shield3.0+ on Raspberry Pi 4 running ubuntu 22.04 pyt

  1. Where did you get the camera module(s)?
  2. Model number of the product(s)?
    OV2311, USB3.0_UC-593_Rev.C
  3. What hardware/platform were you working on?
    Raspberry Pi 4
  4. Instructions you have followed. (link/manual/etc.)
    Jetson/python/streaming_demo (Raspberry Pi didn’t work due to ARCH64)

Setup of Python3.7 environment in ubuntu:
(It has 3.10.4 by default and I want newest version available for other projects)

  1. Problems you were having?
    Two issues:
    This kept happening when trying config parser install

When trying to run streaming demo in a virtual env of python3.7, the camera doesn’t open

  1. The dmesg log from your hardware?

  2. Troubleshooting attempts you’ve made?
    Well, I couldn’t see anything that I could do for the parser make…
    I was trying to use Raspberry Pi steps first, but that wouldn’t even get me this far.

  3. What help do you need?
    I want to get the camera running on a raspberry Pi 4B with Python
    I want to keep new version of python available (prefer running Arducam on 3.10)
    What is your suggested method of running from older versions of python?

This error looks like a permission issue, try running the program with sudo.

For the arm version, currently we do not support python 3.10 other versions you can refer to:

Thank you wong,

It worked!

I ran this (outside of venv)
Sudo ./venv/bin/python3.7 Arducam…

It was tricky running this without uninstalling newer python versions.
But got there in the end.

I suppose creating virtual environments of older python releases is something most people are expected to know.

Great idea, thanks for sharing.