Setup Raspberry Pi Zero with ArduCam 16MP

I tried to setup the 16MP Arducam with a Raspberry Pi Zero and nothing does the job. I tried several steps given in the troubleshooting section from ArduCam as well on Github.

uname -a
Linux raspberrypi 5.15.61+ #1579 Fri Aug 26 11:08:59 BST 2022 armv6l GNU/Linux

cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)" NAME="Raspbian GNU/Linux" VERSION_ID="11" VERSION="11 (bullseye)" VERSION_CODENAME=bullseye ID=raspbian ID_LIKE=debian HOME_URL="http://www.raspbian.org/" SUPPORT_URL="http://www.raspbian.org/RaspbianForums" BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

cat /proc/meminfo
MemTotal: 440264 kB MemFree: 304700 kB MemAvailable: 349524 kB Buffers: 10364 kB Cached: 75540 kB SwapCached: 0 kB Active: 34304 kB Inactive: 67816 kB Active(anon): 728 kB Inactive(anon): 16428 kB Active(file): 33576 kB Inactive(file): 51388 kB Unevictable: 16 kB Mlocked: 16 kB SwapTotal: 102396 kB SwapFree: 102396 kB Dirty: 4 kB Writeback: 0 kB AnonPages: 16248 kB Mapped: 41300 kB Shmem: 940 kB KReclaimable: 9832 kB Slab: 19736 kB SReclaimable: 9832 kB SUnreclaim: 9904 kB KernelStack: 800 kB PageTables: 1048 kB NFS_Unstable: 0 kB Bounce: 0 kB WritebackTmp: 0 kB CommitLimit: 322528 kB Committed_AS: 182444 kB VmallocTotal: 573440 kB VmallocUsed: 5992 kB VmallocChunk: 0 kB Percpu: 64 kB CmaTotal: 8192 kB CmaFree: 6324 kB

Currently my config.txt looks like below …

cat /boot/config.txt
`dtparam=audio=on

camera_auto_detect=1

display_auto_detect=1

dtoverlay=vc4-kms-v3d
max_framebuffers=2

disable_overscan=1

[cm4]
otg_mode=1

[all]

[pi4]
arm_boost=1

[all]
dtoverlay=imx519
dtoverlay=vc4-kms-v3d,cma-512`

dmesg | grep imx512
[ 38.613631] imx519 10-001a: Device found is imx519 [ 38.653900] imx519 10-001a: Consider updating driver imx519 to match on endpoints

libcamera-hello
Preview window unavailable [0:20:22.574584943] [655] INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3866-0c55e522 [0:20:22.665457269] [656] WARN CameraSensorProperties camera_sensor_properties.cpp:174 No static properties available for 'imx519' [0:20:22.666789244] [656] WARN CameraSensorProperties camera_sensor_properties.cpp:176 Please consider updating the camera sensor properties database [0:20:22.751301687] [656] INFO RPI raspberrypi.cpp:1374 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media3 and ISP device /dev/media0 [0:20:22.756121598] [655] INFO Camera camera.cpp:1035 configuring streams: (0) 2328x1748-YUV420 [0:20:22.761161505] [656] INFO RPI raspberrypi.cpp:761 Sensor: /base/soc/i2c0mux/[email protected]/[email protected] - Selected sensor format: 2328x1748-SRGGB10_1X10 - Selected unicam format: 2328x1748-pRAA [0:20:22.769030360] [656] ERROR V4L2 v4l2_videodevice.cpp:1234 /dev/video14[16:cap]: Unable to request 4 buffers: Cannot allocate memory ERROR: *** failed to allocate capture buffers ***

Any help regarding to this topic is appreciated.

@simon_1

pizero cannot be set to 512.

Please modify the config file

dtoverlay=vc4-kms-v3d,cma-128

After reboot, please use the command to check if the configuration is successful.

cat /proc/meminfo

Then use the command normally.

1 Like