RPI Zero 2 W issues with IMX519 not being detected

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)?

  3. What hardware/platform were you working on?
    RPI Zero 2 W

  4. Instructions you have followed. (link/manual/etc.)
    Using libcamera & imx519 on OctoPi

  5. Problems you were having?
    Camera not detected after inputting libcamera-still -t 5000 -o test.jpg -n

[email protected]:~ $ libcamera-still -t 5000 -o test.jpg -n
[0:08:18.878192765] [2008] INFO Camera camera_manager.cpp:293 libcamera v0.0.0
[0:08:18.906438581] [2009] WARN CameraSensorProperties camera_sensor_properties .cpp:141 No static properties available for ‘imx519’
[0:08:18.906533217] [2009] WARN CameraSensorProperties camera_sensor_properties .cpp:143 Please consider updating the camera sensor properties database
[0:08:18.906601811] [2009] ERROR CameraSensor camera_sensor.cpp:551 ‘imx519 10-0 01a’: Camera sensor does not support test pattern modes.
[0:08:18.987336420] [2009] WARN RPI raspberrypi.cpp:1233 Mismatch between Unica m and CamHelper for embedded data usage!
[0:08:18.988300280] [2009] ERROR DelayedControls delayed_controls.cpp:87 Delay r equest for control id 0x009a090a but control is not exposed by device /dev/v4l-s ubdev0
[0:08:18.989015702] [2009] INFO RPI raspberrypi.cpp:1356 Registered camera /bas e/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media3 and ISP device /dev/m edia0
[0:08:18.990203106] [2008] INFO Camera camera.cpp:1028 configuring streams: (0) 2328x1748-YUV420
[0:08:18.990804828] [2009] ERROR V4L2 v4l2_videodevice.cpp:985 /dev/video0[12:ca p]: Unable to set format: Device or resource busy
[0:08:18.991716137] [2009] ERROR V4L2 v4l2_videodevice.cpp:1179 /dev/video0[12:c ap]: Unable to request 0 buffers: Device or resource busy
ERROR: *** failed to configure streams ***

  1. The dmesg log from your hardware?
  1. Troubleshooting attempts you’ve made?
    Tried a fresh reinstall of everything. I have tried two different cameras. They both work on a Pi 4 (even though they freeze for a bit in OctoPrint, but that’s an issue for another day). The Ribbon cable I’m using is also from ArduCam, and I’ve tried multiples of them.

  2. What help do you need?
    .I need help getting passed step ‘libcamera-still -t 5000 -o test.jpg -n’/the camera being detected.

It seems that there is no problem with the driver installation, and the camera has been detected normally.
From the error output of libcamera-still, it seems that the device is occupied by other software, maybe your mjpg-streamer is not closed?
You can turn off the default mjpg-streamer service and try to run libcamera-still.

Check service status:
sudo systemctl status webcamd.service

Stop the service:
sudo systemctl stop webcamd.service

That fixed it. Thank you so much.