RPI Zero 1.3 + 16mpx IMX519 -> illegal operation


Having issue with Arducam IMX519 and Raspberry Pi 1.3 Zero. Started with the latest Raspberry OS Lite (Bullseye, kernel 5.15, February 21st 2023) and working libcamera with OV5647 that was swapped with IMX519.

Followed Quick Start - Arducam Wiki.

  • I installed the driver first (./install_pivariety_pkgs.sh -p imx519_kernel_driver_low_speed). Running libcamera-jpeg -o test.jpg returned:
Preview window unavailable
[1:23:33.907998543] [812]  INFO Camera camera_manager.cpp:299 libcamera v0.0.4+22-923f5d70
[1:23:34.079092329] [813]  INFO RPI raspberrypi.cpp:1476 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media3 and ISP device /dev/media0
[1:23:34.083685297] [812]  INFO Camera camera.cpp:1028 configuring streams: (0) 2328x1748-YUV420
[1:23:34.086664276] [813]  INFO RPI raspberrypi.cpp:851 Sensor: /base/soc/i2c0mux/[email protected]/[email protected] - Selected sensor format: 2328x1748-SRGGB10_1X10 - Selected unicam format: 2328x1748-pRAA
[1:23:34.123205016] [817]  WARN IPARPI raspberrypi.cpp:801 Could not set AF_MODE - no AF algorithm
Segmentation fault
  • Ran ./install_pivariety_pkgs.sh -p libcamera_dev and ./install_pivariety_pkgs.sh -p libcamera_apps
    libcamera-jpeg -o test.jpg returned:
Preview window unavailable
[1:42:32.150664944] [1681]  INFO Camera camera_manager.cpp:299 libcamera v0.0.0+4224-42eae600
Illegal instruction
  • sudo apt update & sudo apt upgrade took my kernel to 6.1.19+. The drivers for IMX519 and AK7375 are included by default (I’ve manually removed the previous ones). However, the issue is the same as above.

Running out of ideas. Any help please?


We have upgraded the focus algorithm.
You need to update the driver of imx519

./install_pivariety_pkgs.sh -p imx519_low_speed

Thanks @Edward

./install_pivariety_pkgs.sh -p imx519_kernel_driver_low_speed gave me:

Cannot find the corresponding package, please send the following information to [email protected]
Hardware Revision: 900093
Kernel Version: 6.1.19+

6.1.19+ is something apt upgrade gave me yesterday (Moving Linux Kernel to 6.1 - Raspberry Pi Forums). Could you add support to that?

In any case, I was on 5.15 two days ago and followed your install instructions but got the same result as with 6.1.

dmesg|grep imx
[    0.153388] platform 20801000.csi: Fixed dependency cycle(s) with /soc/i2c0mux/[email protected]/[email protected]
[   33.531857] imx519 10-001a: Device found is imx519
[   33.532148] imx519 10-001a: Consider updating driver imx519 to match on endpoints
@raspberrypi:~ $ apt show libcamera-apps
Package: libcamera-apps
Version: 0~git20230309+4def288-1
Status: install ok installed
Priority: optional
Section: video
Maintainer: Arducam <[email protected]>


libcamera-still --list-cameras
Illegal instruction

(at least this worked with original libcamera and gave me the supported resolutions but with the original version any attempt to get picture gave Segmentation fault)


We will release the latest kernel driver this week.

Look your libcamera version

dpkg -l | grep libcamera

I also tried the 6.x version, there should be no problem.

Try reinstall libcamera, we recently also update the libcamera.

./install_pivariety_pkgs.sh -p libcamera_dev
./install_pivariety_pkgs.sh -p libcamera_apps

@Edward I just ran again:

./install_pivariety_pkgs.sh -p libcamera_dev
./install_pivariety_pkgs.sh -p libcamera_apps

Result of dpkg -l | grep libcamera afterwards:

ii  libcamera-apps                       0~git20230309+4def288-1          armhf        libcamera-apps
ii  libcamera-dev:armhf                  0~git20230315+42eae600-1         armhf        complex camera support library (development files)
ii  libcamera0:armhf                     0~git20230315+42eae600-1         armhf        complex camera support library
ii  python3-libcamera                    0~git20230302+923f5d70-1         armhf        complex camera support library (Python 3 bindings)

The same problem persists. Could the camera HW be faulty?


I have released the latest kernel imx519 driver

please try again

./install_pivariety_pkgs.sh -p imx519_low_speed


Thanks. I suppose you meant:

./install_pivariety_pkgs.sh -p imx519_kernel_driver_low_speed

The new driver was installed:

$ ls -al /lib/modules/6.1.19+/kernel/drivers/media/i2c/imx519.ko.xz
-rw-r--r-- 1 root root 8436 Mar 21 04:45 /lib/modules/6.1.19+/kernel/drivers/media/i2c/imx519.ko.xz

However, the problem is still there:

$ libcamera-hello
Preview window unavailable
[0:01:07.900838000] [504]  INFO Camera camera_manager.cpp:299 libcamera v0.0.0+4224-42eae600
Illegal instruction

I haven’t mentioned yet, because I don’t see a connection, that after the fresh install of the OS recently, the only thing I did was some tweaking to reduce sdcard wear (inspired by Reducing SD Card Wear on a Raspberry Pi or Armbian Device # Chris Dzombak). After that my old Raspberry Camera Module 1.3 still works so I don’t think that can impact this.



You ar right. My fault.

I need some information

Please reboot your device and execute the following command:

wget -O arducam-camera-bug-report https://github.com/ketai-dhr/arducam-camera-bug-report/releases/download/tools/arducam-camera-bug-report
chmod +x ./arducam-camera-bug-report

This will output an arducam-bug-report.txt in the current directory.

Please send this file to me via google cloud disk or similar platform or email ([email protected])

Thank you for your cooperation and have a nice life.

@Edward Thanks. Just sent it by email.