Rpi 4 cannot detect video 0 on Arducam 8MP Synchronized Stereo Camera Bundle Kit

1.Which seller did you purchase the product(s) from?
someone brought for me
2.The Model number of the product(s) you have purchased?

3.Which Platform are you using the product(s) on?
Raspberry Pi 4B
4.Which instruction are you following?
5.Has your product ever worked properly?
Never worked
6.What problems are you experiencing?
I tried to follow the instruction on your website.
I did “sudo nano /boot/config.txt” and installed the driver already and then enabled the camera from raspi-config.

However, when I type “vcgencmd get_camera”. it output detected=0.
I cannot detect even one camera from the board.

When I type “ls /dev/video*”, It only shows video10 video11 video12 video13 video14 video15 video16 but not video0
7.What attempts at troubleshooting have you already made?
I tried to update back to kenel 5.4.51-v7l+ because some site said driver is not compatable on newer kernel version. I also tried UC440 pin connect directly to UC-506 CamA and It didnt work too
8.How would you like us to help you?
please help me to detect the video 0 so that I can