Quad Camera Hat Sync fix?

I had this issue 5 months ago (others experienced this problem too) where the hat produced a hybrid desynced image in the 1/4 res mode (2 pairs of synchronized images with a delay of roughly half a second between the 2 pairs) and I need all 4 to be synced.
At the time I was advised to raise the framerate which didn’t fix the issue and sacrificed quality.

Is there now a fix so that all the images are in sync, and if not can anyone fix it? The camarray hat page did not and does not state such limitations and I cannot use it as it should for my project.

  • Where did you get the camera module(s)?
    Arducam preorder
  • Model number of the product(s)?
    64MP Autofocus Quad-Camera Kit for Raspberry Pi
  • What hardware/platform were you working on?
    Raspberry Pi 4B 4GB - Raspberry Pi OS
  • Instructions you have followed. (link/manual/etc.)
    PDF guide for quad camera + libcamera guides from arducam site
  • Problems you were having?
    Desynchronisation
  • The dmesg log from your hardware?
    [ 11.570086] arducam_64mp: loading out-of-tree module taints kernel.
    [ 11.583608] arducam_64mp 10-001a: Device found Arducam 64MP.
    [ 11.586992] arducam_64mp 10-001a: Consider updating driver arducam_64mp to match on endpoints
  • Troubleshooting attempts you’ve made?
    I tried to reduce shutterspeed and iso settings, tried raw format, lowering the resolution

Theoretically speaking, there is one frame delay between the two pairs of cameras. Hence, the delay is dependent on the framerate you choose.