Problems capturing image from OV5647

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)?
    Arducam 5MP OV5647 Camera Module with IR Cut and LED for Jetson Nano (Jetvariety RAW 5)

  3. What hardware/platform were you working on?
    Jetson Xavier NX (Using the Developer Kit), JetPack 5.0.2

  4. Instructions you have followed. (link/manual/etc.)
    Quick Start Guide - Arducam Wiki
    Toubleshoot - Arducam Wiki

  5. Problems you were having?
    When following the quick start guide I try to capture the image from the camera but it doesn’t recognize the format and shows the error below: (I also tried the others ximagesink (xvimagesink), glimagesink)

gst-launch-1.0 v4l2src device=/dev/video0 ! video/x-raw, format=BG10, width=640, height=480 ! videoconvert ! xvimagesink 

Return: (Unfortunately I couldn’t attach another image as I’m a new user)

WARNING: erroneous pipeline: could not link v4l2src0 to videoconvert0, neither element can handle caps video/x-raw, format=(string)BG10, width=(int)640, height=(int)480

  1. The dmesg log from your hardware?
    How can I share the dmesg log as the only option here is to upload images?

  2. Troubleshooting attempts you’ve made?
    Then I went and tried the troubleshoot on the second link and when I got to the step “Running Gstreamer.” it also doesn’t work returning the error of cameras not available as shown below: (I had to change from “nvoverlaysink” to “nvdrmvideosink” as the former is not supported anymore on Jetpack 5.0.2)

gst-launch-1.0 nvarguscamerasrc sensor-id=$SENSOR_ID ! "video/x-raw(memory:NVMM),width=640,height=480,framerate=$FRAMERATE/1" ! nvvidconv ! nvdrmvideosink

  1. What help do you need?
    I need help to understand and fix what’s wrong so I can capture the image from the OV5647

Please execute the commands
‘dmesg | grep ov5647’ and ‘ls /dev/video0’

Send us the screenshot in the terminal.


As requested the print is below, I don’t know if it’s right but the dmesg didn’t return anything.

Screenshot from 2022-12-15 18-44-10

Trying to share more information about the error, I cleared the dmesg, tried connecting to the camera as shown in the troubleshooting and printed the erros shown on the dmesg.