Problem with Arducam for Jetson Nano with L4T 32.5.1

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Jetson Nano

I’m trying to install Arducam camera drivers on jetson nano with L4T 32.5.1 (4.9.201-tegra kernel) using the script provided by this link.
After I reboot, I get stuck in the boot and cannot proceed. Almost no command works and there seem to be lots of system files missing. This is what I see after I reboot:

What should I do to fix this driver and get the camera working without messing up anything?

I just noticed that the image I uploaded is not showing. here it is:

Hello @atab

How do you use the automatic installation script?
This script just gets the current system information, finds the corresponding deb installation package, and installs it.

The deb package will perform the following operations:

  1. Back up /boot/Image as /boot/Image.bak
  2. Back up /boot/extlinux/extlinux.conf to /boot/extlinux/extlinux.conf_bak
  3. Replace /boot/extlinux/extlinux.conf file
  4. /boot/Image will be replaced after restart

If you cannot boot after installing the deb package, you can restore it by the following operations:

  1. Take out the SD Card and insert it into the computer using a card reader
  2. Use /boot/Image.bak to overwrite /boot/Image
  3. Use /boot/extlinux/extlinux.conf_bak to overwrite /boot/extlinux/extlinux.conf
  4. Insert the SD Card into Jetson and turn it on.


I followed instructions in .

your instructions on restoring the image saved me a lot of time flashing the sd card. Thanks. But I still can’t get the camera to work and same issue persists.

Hi @wironomy

Can you provide this information?

Hi @wong

There is no camera device in /dev/video* and only the AR0230 Arducam is connected to jetson nano.

~$ dmesg | grep -E “arducam|imx219|imx477”
[ 1.295331] imx219 7-0010: tegracam sensor driver:imx219_v2.0.6
[ 1.318752] imx219 7-0010: imx219_board_setup: error during i2c read probe (-121)
[ 1.318818] imx219 7-0010: board setup failed
[ 1.318869] imx219: probe of 7-0010 failed with error -121
[ 1.319328] imx219 8-0010: tegracam sensor driver:imx219_v2.0.6
[ 1.342690] imx219 8-0010: imx219_board_setup: error during i2c read probe (-121)
[ 1.342749] imx219 8-0010: board setup failed
[ 1.342796] imx219: probe of 8-0010 failed with error -121


Note that I have restored the Image and config file to the original, so the driver is not working. Also, I tested it with multiple cameras of the same kind, the error is the same.

this is the link to dmesg.log

Hi @wironomy

Thank you for the information,
I tested it on my Nano, and everything looks normal.
Let me confirm again, your current problem is that Jetson Nano cannot boot after installing the driver, right?

If so, we need to perform some tests to locate the problem:

  1. Open /boot/extlinux/extlinux.conf and replace LINUX /boot/Image with LINUX /boot/arducam/Image
    Restart Jetson Nano to see if it can boot normally.
    (The purpose here is to replace the kernel with the kernel compiled by arducam to confirm whether it is a kernel file problem. Please make sure that the /boot/arducam/Image file exists before replacing it)
    If it can boot normally, then there is no problem with the kernel.

  2. Open /boot/extlinux/extlinux.conf and add the following line
    FDT /boot/arducam/tegra210-p3448-0000-p3449-0000-b00-arducam.dtb
    (The purpose here is to replace the device tree file. Please make sure that the /boot/arducam/tegra210-p3448-0000-p3449-0000-b00-arducam.dtb file exists before modifying the file)

Hi @wong,

Thank you for your reply.

Yes, this problem happens after I install the driver using script. I tried the steps you have provided. In the first step jetson boots normally, but with few warnings at boot time messages. When I add the device tree file (second step), the problem shows itself. Note that in the second step I used the arducam Image (same as first step).

So it seems that the problem is with device tree file.

Hi @wong

I also checked this with the following versions of Nvidia Jetson image(L4T 32): 5.1 , 5.0 , 4.4.1, 4.4. Same problem!!!

I really don’t know what to do.

Hi @wironomy

Sorry for your bad experience, i will try my best to solve your problem.

This is weird, have you tried removing the camera and starting Jetson?
This may be a problem caused by the camera.

Another thing you can do:
The screen photos provided above do not see valid information. You can get the complete log through the UART on Jetson. It would be best if you can provide a complete system log.

Hi @wong,

I was able to solve this problem. I just reflashed the jetson framework, and it worked. It seems like my endeavors in custom Linux on jetson a few months back had some unseen ramifications. As I had done this on my other jetsons, I did not notice that was the problem. Anyways, thanks for your help and time.

I was wondering if I were to make and install a custom Linux, what should I do to make this camera driver work?

Hi @wironomy

Glad to hear that your problem has been solved,
If you are customizing linux, then you’d better add the arducam driver code to compile together.

Hi @wong

Thanks for everything. Where can I get the driver code ?? How should I compile it with Linux?

Hi @wironomy

Tell me your e-mail address, or contact [email protected] via e-mail and attach the L4T version you need, and I will send you the driver patch by email.