I see that you have a good support of the OV9281 for the RPI. Would it be possible to port the drivers for the Jetson Nano? Do you plan on doing this in the near future?




Yes, at present, we are developing our mipi camera’s driver on Jetson Nano platform.

That’s very good news.

Do you have a timetable for the release?


We expect release it in the first half of this year.


Hi there, I too would be extremely interested in seeing support of the OV9281 for the Jetson Nano, especially as if you click on the “Jetson cameras” link on your website, the first camera that appears it the OV9281!!!

How is progress going on supporting this on Jetson Nano?

Can you provide a DTS file or section of a DTS file to show what changes need making?

Thank you.

Hi @ov9281_for_jetson,

You can check this document for more information:
MIPI Camera Modules for Jetson Nano

Hi @wong

Is the driver actually for the OV9281 or the Jetvariety adapter board? Doesn’t the Jetson already have native support for the OV9281?

Hi @kerfuffle ,

We are very sorry, but there have been some problems in our system recently, which caused us not to see your reply.
Not sure if your problem has been resolved, here is the response to the problem:

Jetson does not natively support OV9281. Using OV9281 on Jetson requires Jetvariety adapter board. Currently we do not sell Jetvariety adapter board separately.

Best Regards,


I am trying to use the camera B0223 with Jetson Nano dev. kit.

Here there is my software versions:

uname -a
Linux dvjes-nanokit43 4.9.140-tegra #1 SMP PREEMPT Mon Dec 9 22:47:42 PST 2019 aarch64 aarch64 aarch64 GNU/Linux

cat /etc/nv_tegra_release

R32 (release), REVISION: 3.1, GCID: 18186506, BOARD: t210ref, EABI: aarch64, DATE: Tue Dec 10 06:58:34 UTC 2019


I followed this steps: https://www.arducam.com/docs/camera-for-jetson-nano/mipi-camera-modules-for-jetson-nano/driver-installation/

- When I tried to install driver using the script I got the following output:

Cannot find the corresponding deb package, please send the following information to [email protected]
Kernel version: 4.9.140-tegra-32.3.1-20191209225816
Jetson type: Nano (Developer Kit Version)


- In this repository: https://github.com/ArduCAM/MIPI_Camera/tree/master/Jetson/Jetvariety/driver/Nano

I don’t find the correct version as all packages are arducam-nvidia-l4t-kernel_4.9.140-tegra-32.3.1-2020XXXX and mine should be arducam-nvidia-l4t-kernel_4.9.140-tegra-32.3.1-2019XXXX.

I tried with all packages arducam-nvidia-l4t-kernel_4.9.140-tegra-32.3.1-2020XXXX but it does not work.


I can not update my system to a newer Jetpack version. Please help me.

PS: I have the same problem with this camera B0249 (sorry I know it is not on this topic)