OV9281 RaspberryPi V4L2 driver is not working

1.Which seller did you purchase the product(s) from?
robot shop
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Raspberry pi CM 4 IO board
4.Which instruction are you following?
5.Has your product ever worked properly?
Never worked
6.What problems are you experiencing?

so I just got this camera module: https://www.arducam.com/product/arducam … pberry-pi/ from Arducam.

And after that I connected the module with the comput module 4 IO board through the CAM0 CSI-2 interface.
And I fitted the 2 jumpers on J6 for the I2C communication for CAM0.

Next, I added “dtoverlay=ov9281” to the config file, to enable the camera module.

Finally I booted the pi and checked the loaded driver with “modinfo ov9281”, and it is the one located at “/lib/modules/5.10.46-v7l+/kernel/drivers/media/i2c/ov9281.ko”. Everything as expected so far.

But checking the dmesg I see the following error:

[ 7.098148] ov9281 10-0060: Unexpected sensor id(d0fc2400), ret(-5)

And I also have no device at /dev/video0.

As you can see above, my kernel version is 5.10.46-v7l+


Checking the driver here: https://github.com/raspberrypi/linux/blob/rpi-5.10.y/drivers/media/i2c/ov9281.c

I see that this rpi driver only supports 2 lanes MIPI CSI-2, but on the board only 1 data lane is routed from the camera board to the raspberry pi. So it doesn’t surprise me that this driver isn’t working. But since the Arducam website says that it has official RaspberryPi support, it strikes me to see that it’s not easy to find.

I want to use the kernel mode driver only, not the userspace one. So could you please provide me a working driver ?
7.What attempts at troubleshooting have you already made?

8.How would you like us to help you?
through this forum

Ok, I just checked again, and it does seem to have 2 data lanes connected. So that observation earlier was wrong.

But the error still stands. Any input on that would be great

Solution is documented here: https://www.raspberrypi.org/forums/viewtopic.php?f=43&t=317517


The problem was that the device tree file uses the CAM1 interface on the IO board as default. So to get it working all I had to do, was to attach the camera to the CAM1 CSI-2 interface.