OV9281 not working/freezes with raspberry pi 4 b - No preview image or file

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Raspberry Pi 4B 4GB w/ 32GB Sanddisk SD Card using HDMI0 to a monitor at 1920*1080
4.Which instruction are you following?
I first followed the instructions here in the quick start guide: https://www.arducam.com/docs/cameras-for-raspberry-pi/migrated/ov9281-1mp-global-shutter-raspberrypi-camera/, and then the one here https://github.com/ArduCAM/MIPI_Camera/tree/master/RPI
5.Has your product ever worked properly?
6.What problems are you experiencing?
I have tried on a fresh install of raspberry pi os still doesn’t work.

When i did this i first followed the tutorial here, and I managed to see a preview of the camera using Yavta, but the image was extremely dark. After this I followed the tutorial on github, including the section marked "For PI 4 Platform, as well as every other step. When i run ./arducamstill, i get the following error:

After this the program gets stuck and I have to manually close the termina; (doesn’t respond to ctrl-c). I note that it stops before the example screenshots on the Github tutorial says ‘can’t open the file’, perhaps it tries to open a file and cannot terminate that process? Just a guess.

Interestingly, the second time I tried it I forgot to do the quickstart guide and when I ran arducamstill it got further to the line where it said “Start Preview”, but still got no preview and it did not write any images. When i then put ‘dtoverlay=ov9281’ into config.txt it went back to how it was in that screenshot above.
7.What attempts at troubleshooting have you already made?
I have tried rebooting, giving 512mb of GPU memory etc. I really can’t figure out what’s the problem. I’ve checked I have it connected to the PI correctly which I believe i do.
8.How would you like us to help you?
Suggestions for fixes


Don’t worry and I will try my best to help you.

For the OV9281 sensor, it has two drivers, the unicam and MIPI_Camera, if you want to visit the camera through the v4l2 tool or yavta, you should add dtoverlay=ov9281 to the /boot/config.txt file. If you want to use MIPI_Camera driver and ./arducamstill application, you should delete or comment the dtoverlay=oc9281. Because both of them can’t work at the same time. Please comment the dtoverlay=0v9281 and refer to the user guide here





Hi, I have now uncommented dtoverlay=ov9281, although I now progress slightly further in the arducamstill program (I see the green text and it no longer crashes my terminal), i get no preview of the video. When i add -o test.jpg as an argument, it gets stuck on encoding the image and i get an error telling me the encoder has timed out.


Recently I am optimizing the MIPI_Camera driver in order to compatible with CM4 and other system. Some problems may be occurred during the debug. Please download the latest version to try. tomorrow I have updated the latest version. Feel free to let me know if you need more help. I will keep on updating the lib.