Not able to use Arducam multicam adapter with IMX219 8 MP cameras

Hi,

I have a Multi-Camera Adapter Board V2.2 with four IMX219 Color Cameras connected to it and I have mounted the entire setup on Raspberry Pi 3b+ with the latest version of Buster OS.

I have followed all the steps mentioned in this link but could not see any address for $ i2cdetect -y 0.

And there seems to be no video0 device,

$ ls /dev/video0
ls: cannot access ‘/dev/video0’: No such file or directory

I ensured connections are correct and added dtparam=i2c_vc=on to /boot/config.txt and rebooted hardware. Could you please help me if I am missing anything?

Thanks,
Manjunatha

@ManjunathaVG
Please take a photo of the hardware connection, and give me the info of cat /boot/config.txt

@Edward - Thanks for replying, here is the picture of the hardware connection and /boot/config.txt file

/boot/config.txt

For more options and information see

http://rpf.io/configtxt

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode

#hdmi_safe=1

uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan

#disable_overscan=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border

#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=1280
#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output

hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)

hdmi_group=1
hdmi_mode=4

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes

#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

dtparam=i2c_arm=on
#dtparam=i2s=on
dtparam=spi=on

Uncomment this to enable infrared communication.

#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on

[pi4]

Enable DRM VC4 V3D driver on top of the dispmanx display stack

dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d
start_x=1
gpu_mem=128
enable_uart=1
dtparam=i2c_vc=on

ok
Try adding dtoverlay=imx219 at the end of your /boot/config.txt file

@Edward - I added dtoverlay=imx219 and rebooted the pi but still no luck.
Here are the results of some commands,

[email protected]:~ $ dmesg | grep imx219
[ 9.119185] imx219 10-0010: failed to read chip id 219
[ 9.120387] imx219: probe of 10-0010 failed with error -5
[ 33.754801] imx219_vddl: disabling
[ 33.754826] imx219_vdig: disabling
[ 33.754848] imx219_vana: disabling
[email protected]:~ $ i2cdetect -y 0
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – – – – – – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: – – – – – – – – – – – – – – – –
30: – – – – – – – – – – – – – – – –
40: – – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: – – – – – – – – – – – – – – – –
70: – – – – – – – –
[email protected]:~ $ v4l2-ctl --list-devices
bcm2835-codec-decode (platform:bcm2835-codec):
/dev/video10
/dev/video11
/dev/video12

bcm2835-isp (platform:bcm2835-isp):
/dev/video13
/dev/video14
/dev/video15
/dev/video16

Cannot open device /dev/video0, exiting.
[email protected]:~ $ ls /dev/video0
ls: cannot access ‘/dev/video0’: No such file or directory
[email protected]:~ $

Hi,
The log: “imx219 10-0010: failed to read chip id 219” means can’t detect the sensor. Most of time, it is due to the hardware connection,especially the powr en and i2c pins. Please ensure and check the csi cable line and change another cable line if you have extra one.

Hi,
Thanks for suggesting it.

I am still seeing the same issue even after changing the cables for all cameras.

Can I connect these cameras directly to the Raspberry Pi CSI connector and check? Is it safe to do so? Because somewhere in the documentation I remember reading about one of the cameras doesn’t work with a direct connection to Raspberry Pi.

BTW I am using FFC Cable Type B, not sure if this is relevant just posting it here

Thanks,
Manjunatha

Hi,
The cable line is right. You can remove the adapter board and connect the camera to the PI’s CSI port directly.
Don’t worry and I will help you solve all of your issue.

Hi,
Thanks a lot for volunteering to help me on this issue, and, sorry for my delayed response.

So far I have tried direct connection workflow (Camera → CSI of Raspberry Pi)on Raspberry Pi 3b+, B+, and Zero with Buster and Bullseye OS and I still see the same issue where dmesg says “imx219 10-0010: failed to read chip id 219”. Not sure what I am missing here.

Just an FYI, I am using IMX219 cameras from Camera Bundle Kit, not sure if this is causing the issue.

Thanks,
Manjunatha

Hi,
Oh,If you are using camarray, you can’t use the single camera, due to the hardware is specific. Please attach me your hardware picture, I need to ensure the camera you are using.

Hi,
Oh my bad, didn’t realize that camarray cameras are not compatible with the multicam adapter boards. Thanks a lot for letting me know. Here is the picture of camera that I have,

Thanks,
Manjunatha

Hi,
Just another tiny help, can you please share the compatible cameraboard purchase links for the Multicamera adapter module v2.2 which I have? I really appreciate it if you could share the links, any 5/8MP cameras with basic functionality would do.

Thanks,
Manjunatha

@ManjunathaVG

Hi, for any inquiries about purchasing a camera, please contact [email protected]
They will answer more professionally and in detail

Thank you!

-Manjunatha