No cameras available

1.Which seller did you purchase the product(s) from?
2.The Model number of the product(s) you have purchased?
3.Which Platform are you using the product(s) on?
Jetson Nano A02
4.Which instruction are you following? but started checking out the other demos in MIPI_Camera when it didn’t work
5.Has your product ever worked properly?
Never worked
6.What problems are you experiencing?

Recently purchased the 8MP PTZ camera from UCTRONICS for my Jetson Nano A02. I can get the focus and zoom to work but cannot get anything from the camera.

Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:557 No cameras available
[ WARN:0] global /home/nvidia/host/build_opencv/nv_opencv/modules/videoio/src/cap_gstreamer.cpp (933) open OpenCV | GStreamer warning: Cannot query video position: status=0, value=-1, duration=-1
Exception in thread :
Traceback (most recent call last):
File “/usr/lib/python2.7/”, line 801, in __bootstrap_inner
File “”, line 92, in run
error: OpenCV(4.1.1) /home/nvidia/host/build_opencv/nv_opencv/modules/highgui/src/window.cpp:352: error: (-215:Assertion failed) size.width>0 && size.height>0 in function ‘imshow’
7.What attempts at troubleshooting have you already made?
Checked the ribbon cable several times as well as other demos
8.How would you like us to help you?
Help debugging. Or replacement



Hi @jbsulli ,

We are very sorry, but there have been some problems in our system recently, which caused us not to see your reply.
Not sure if your problem has been resolved, here is the response to the problem:

Has your problem been solved? It seems to be a problem with the older version of the driver.

Best Regards,