New Stereo Camera HAT, new PI installation, not working

  1. Where did you get the camera module(s)?

ArduCam store
Order #1000016025 (most recent, cannot get HAT to work)
Order #1000010646 (previous, cannot get HAT to work)

  1. Model number of the product(s)?
  1. What hardware/platform were you working on?

Raspberry Pi 4B, 8 GB

  1. Instructions you have followed. (link/manual/etc.)
  1. Problems you were having?

After successfully installing the driver and restarting, the camera is not detected on I2C bus, and none of the commands work except listing available video modes.

The device /dev/video0 is present.

preview-dualcam prints “init camera status = 4100”

arducamstill prints this and exits:

“Hardare version: d03114”
“No match to harware version!”
“Device /dev/video0) opened.”
“select timeout”

raspistill -t 0 -p 800,100,1024,768 prints this and exits:

mmal: Cannot read camera info, keeping defaults for OV5647
mmal: mmal_vc_component_create: failed to create component ‘’ (1:ENOMEM)
mmal: mmal_component_create_core: could not create component (1)
Failed to create camera component
Camera is not detected. Please check carefully camera module is installed correctly

In /boot/config.txt I have:




  1. The dmesg log from your hardware?

Booting Linux on physical CPU 0x0
Linux version 5.4.79-v7l+

Machine model Raspberry Pi 4 Model B Rev 1.4

Memory: 7604180K

vc-mem: 1024 MiB

vc_sm_cma: module is from the staging directory, the quality is unknown, you have been warned
bcm2835_vc_sm_cma_probe: Videocore shared memory driver
vc_sm_connected_init: Installed successfully
videodev: Linux video capture interface: v2.00
bcm2835_mmal_vchiq: module is from the staging directory, the quality is unknown, you have been warned
bcm2865_isp: module is from the staging directory, the quality is unknown, you have been warned
bcm2835_v4l2: module is from the staging directory, the quality is unknown, you have been warned
bcm2835-isp bcm2835-isp: bcm2835_isp_get_supported_fmts: port has more encoding than we provided space for. Some are dropped.

… Device node output[0] registered as /dev/video13
… Device node capture[0] registered as /dev/video14
bcm2835_codec: module is from the staging directory, the quality is unknown, you have been warned
… Device node capture[1] registered as /dev/video15
… Device node stats[2] registered as /dev/video16

Loaded V4L2 bcm2835-isp
… Device registered as /dev/video10
Loaded V4L2 decode
… Device registered as /dev/video11
Loaded V4L2 encode
… Device registered as /dev/video12
Loaded V4L2 isp
… bound fe600000.firmwarekms (ops vc4_fkms_ops [vc4])
brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
… Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt failed with error -2
[drm] Initialized v3d 1.0.0 20180419

  1. Troubleshooting attempts you’ve made?

Re-connected camera cables and HAT several times.
Read and tried all troubleshooting guides (listed above).
Ordered one more Arducam package, does not work out of the box.
Got a new SD card for Raspberry Pi with pre-installed operating system (Raspbian Buster), does not work.
Imaged a new SD card for Raspberry Pi with new operating system (Raspberry Pi OS 2020), does not work.
Got a new Raspberry Pi 4B 8GB, followed setup guide again, still does not work.
Installed all available updates.

  1. What help do you need?

New Arducam Stereo Hat that I just ordered does not work. Please help me get it working. This is the second one I bought that doesn’t work.

Hi @01binary

You just need to refer to:

Do not use MIPI_Camera, they are conflicting.

There is an arducamstill in

Hello, I re-imaged my SD card to start from scratch and make sure I follow your instructions exactly from a brand-new Raspberry Pi OS 2020 installation:

I downloaded the driver after you confirmed this is the correct driver for Stereo Camera Hat with NoIR cameras:


This instruction didn’t work because the file is called arducam_obisp_camera_driver.tar.gz and not Release.tar.gz, but extracted fine once the correct file name was used:

tar zxvf Release.tar.gz

This instruction didn’t work because the resulting folder was named arducam_obisp_camera_driver instead of Release, but worked fine after using the correct folder name:

cd Release/

Driver installation didn’t work because there was no script called ./, but worked once I used the correct name ./


I restarted as the guide suggests by entering “y” and hitting enter after the installation completed successfully.

When I opened /boot/config.txt, dtoverlay=arducam and gpu_mem=400 was successfully added to the end of the file.

Then I checked for video0:

ls /dev/video0

This listed video0 as expected.

Then I listed available video modes. This did not match the screenshot in the guide, as many more modes were listed, but the output looked similar.

  • Screenshot: only lists 2560x800 in GREY, Y10P and Y10
  • Actual Output: lists 2560x800, 2560x720, 1280x400, 640x200 in same three color modes

Finally, I used arducamstill to preview camera feed in #RAW8 format:

arducamstill -t 0 -pixfmt GREY -w 2560 -h 800

Just like before, this command printed the following after hanging for a few seconds:

Hardare version: d03114
No match to hardware version!
Device /dev/video0) opened.
Video format set: GREY (59455247) 2560x800
select timeout

Can you advise what’s wrong with Arducam and how to proceed?

I’m very sorry, there is indeed a problem with the installation tutorial on the web page you mentioned, and we are updating it. The correct installation tutorial is as follows: V4L2 OBISP Driver for the Latest RPi OS Updates (Kernel 5.4.79 and later) - Arducam the-lastest-rpi-2020-12-02-update/, if you follow this document, the camera still does not work, can you send us the camera connection diagram?

Hello, I just got a brand new Raspberry Pi 4B 8GB and official Raspberry Pi power supply to confirm that this is not a problem with my hardware. I also got a new NOOBS card with last year’s version of Raspbian.

Following your new instructions, I got the same behavior.

  • Calling arducamstill with a specific format prints a “select timeout” error
  • Calling arducamstill only with -t 0 prints “Unable to set format: Invalid argument (22)”
  • Listing video0 still returns video0.
  • The list of formats looks the same

Here’s my setup:

  • Using new Raspberry Pi that I got yesterday
  • Using new Raspberry Pi power supply
  • Using new SD card with Buster 2019
  • Installed all updates with --allow-releaseinfo-change because Buster is deprecated
  • Followed instructions in the original guide, except the section that was in the new guide for installing the driver

How should I proceed?

Hello, I am running our driver on the latest Raspberry Pi system. No problems were found in the test results. The test process is as follows:

  1. Download the driver: wget
  2. Unzip the compressed package: tar zxvf arducam_obisp_camera_driver.tar.gz arducam_obisp_camera_driver
  3. Configuration environment: ./
  4. Wait for the system to restart
  5. Check whether video0 exists: ls /dev/video0. If video0 exists, proceed to the next step. If it does not exist, check the connection of the camera.
  6. Check the data output format supported by the camera: v4l2-ctl --list-formats-ext -d /dev/video0
  7. Select the data format and resolution supported by the camera: arducamstill -t 0 -pixfmt GREY -w 2560 -h 800
    Feel free to let me know if you need more help.

Hello, I encountered an error between step 3 and 4 of your instructions. I assume you wanted me to follow these instructions from scratch on a new Raspberry Pi OS installation. The error is as follows:

Start updating system...
Enable i2c0 adapter...
modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/5.10.17-v7l+/modules.dep.bin'
modprobe: FATAL: Module i2c-dev not found in directory /lib/modules/5.10.17-v7l+
Add dtoverlay=arducam to /boot/config.txt
Add gpu=400M to /boot/config.txt
Add cma=128M to /boot/config.txt
reboot now?(y/n)

This error sounded to me like it was complaining about Camera and/or I2C interface not being enabled in raspi-config options. I enabled those, rebooted, then this step completed successfully.

I listed video: ls /dev/video0 and got /dev/video0 output, as before. Note that I see the activity lights on the camera hat blinking when they initialize at boot time: 2 blinks when turned on, and 2 more blinks a second or two later.

Next I listed formats by using v4l2-ctl --list-formats-ext -d /dev/video0:

Finally, I executed arducamstill -t 0 -pixfmt GREY -w 2560 -h 800 and got the same output again:

Hardare version: d03114
No match to hardware version!
Device /dev/video0) opened.
GREYemphasized text
Video format set: GREY (59455247)
[about 15 seconds later...]
select timeout

When I execute i2cdetect -y 0 I get a blank list, no I2C devices detected.

Here’s a picture of my setup again.

I got a package of Arducam cables and used a brand-new camera cable, also the shortest one in case the longer cable made the signal too weak.

I noticed that your instructions are sometimes missing detail, for example in the post above you said your test setup works with the numbered list of steps, but then there was a setup step missing. Do you think there are more steps that are missing, like downgrading drivers, verifying operating system version, installing or not installing updates? I can make a complete video starting from connecting and installing Raspberry Pi OS to the last error message if you like.

Lastly, you can verify that this is at least the third Arducam I bought from you - it’s a significant investment I made only because I loved your product and believed it could really help me. If this order was shipped with bad hardware, could I ship it back and get a new one? If you notice that I fried some part of the board due to poor handling (I assure you, I really tried to be careful) then I’m OK with paying for the repair or a new one. I can also cover the shipping.

I hope you can understand that I don’t want to spend many weeks or months troubleshooting this hardware and would love to continue with my project once this piece works. At this point, I have replaced the Raspberry Pi itself, the power adapter, the SD card, the camera ribbon cable, and the operating system, so I am out of parts to replace except for the Arducam itself. I also disconnected and re-connected all ribbon cables, the ones to the cameras and the ones to the Pi.

Could you reply please? I poured a lot of money into ArduCam and my project is stuck because the one you sent me does not appear to work (or missing instructions because your tests are running with outdated software).

Hello, I am very sorry for taking so long to reply to you, because we had a holiday a few days ago and we only officially started work today. I looked at your camera connection and found no problem, and the camera driver configuration process is also no problem. You can contact our after-sales staff for return and exchange.

Hello, when running the arducamstill -t 0 -pixfmt GREY -w 2560 -h 800 command, does the green light on the Camarray HAT board flash twice?

Hello, thank you for getting back to me and I hope your vacation was good.

I confirmed that when running arducamstill -t 0 -pixfmt GREY -w 2560 -h 800, the green light on the HAT does flash twice.

Hello, I want to confirm. Did you buy two sets of Camarray HAT? Neither of these two sets of Camarray HAT can be used normally?

Yes, neither of these two sets can be used normally. I mentioned both orders in this topic to communicate that I really tried to get this working and didn’t mind extra investment in your product if that’s what it took. In addition, I wanted to highlight that software might be the problem, since the other HAT (Order #1000010646) used to work before, and stopped working with Raspberry PI OS updates this year.

I only need a single Camarray HAT to work normally, so if you think there is a hardware issue, I would like to repair or replace just the latest one (Order #1000016025).

Hello, I sent you an email, you check the email.

Is the camera boards he using in this the monochrome quadrascopic because i have the 4 camera version of this board i have two of these the revision D1 and C i can’t get either to work with raspberry pi 4b 8gb model