Mini 5mp Plus JPEG Header Problem

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)?
    Mini 5mp Plus JPEG

  3. What hardware/platform were you working on?

  4. Instructions you have followed. (link/manual/etc.)

  5. Problems you were having?
    There is no jpeg header

  6. The dmesg log from your hardware?

  7. Troubleshooting attempts you’ve made?

  8. What help do you need?
    I am using ArduCAM mini 5mp plus with nRF52 platform.
    I implemented the Arduino library for nRF52 and I can see the SPI and I2C data without any problem.
    Originally, I am trying to send the JPEG data to the phone over BLE and I am using this example project GitHub - NordicPlayground/nrf52-ble-image-transfer-demo at feature_upgrade_to_sdk15
    The library that ported is working fine I guess. But somehow I can’t get the JPEG header.
    When I debug the mobile app it gives ‘JPEG header is missing’ error.
    When I try to send the JPEG data that I receive from the ArduCAM to the UART port, I can’t see the JPEG header either.
    In Arduino examples, I see that there are some special patterns like 0xD8 0xFF or 0xD9 0xFF, but I can’t see these data on my UART end.
    Here are the files
    Can someone tell me what am I doing wrong or missing?

The JPEG header is “0xFFD8” and the jpeg tail is “0xFFD9”.
If the camera works in jpeg mode, it will output the jpeg head and tail. we have tested it on Arduino UNO ESP32 Mega2560 .etc platform. If the image data does not exist jpeg header, maybe it is due to the sensor configuration abnormal. Please ensure each i2c operation is normal. As normal, you should add some delay to make sure each i2c operation is valid, Shown as the following image:

Let me know if you need more help.

Thank you so much for such a great and simple suggestion.
It worked and I am not happy about it.
I was expecting something more complex than that :smiley:
But hey, I worked. It is all that matters now… :smiley: