update and FAQ

Our script for installing the driver has been upgraded. You can restart the installation script experience. At present, the script does not support the use of CM3/CM4. It does not maintain some older versions of the Raspberry Pi system.

cd ~
wget -O
chmod +x ./

Detect the camera and automatically install the corresponding driver for you.

sudo ./ -d

You no longer need to restart the system for the camera to take effect, but due to the previous installation package, we will not rebuild all installation packages for this small update. After installing the driver, you can choose to run the camera directly without restarting.

Like this,if you see a prompt similar to the structure in the picture below, you can choose not to restart,otherwise a restart is required.


When I execute “./ -d” I get this error message:

./ line 96: /etc/modules: Permission denied

but it appears to run anyway and at the end I get:
Your camera does not need to install drivers.

So, Is this cool ? (I still do not see /dev/video0 or /dev/video1 ) so we are not home and hosed just yet.


Many operations require administrator privileges, so perhaps using sudo will make this less of an issue in the future.

The prompt that appears means that the i2c is not being read correctly, or that your camera does not need a driver installed. Can you give me any information about your camera model?

ThanksEdward for responding.

Maybe you are right, but I don’t run the scripts out of nowhere, and do not think them up myself.

The command lines are cut and pasted from various “how to” documents provided by your company. Sudo is often present in such copied and pasted lines, but not always.

Anyway this issue is not longer happening or not a problem, can be closed

Thanks and cheers
Bryn Parrott


I apologize for this, it’s a new feature still in beta and I’m grateful to the users who helped me discover this issue before it was released. Progress together.

By the way, in fact the most significant issue was found to be in build of ‘’ which is part of the mjpg-libcamera installation.

There was a bug in one file (/libcamera/controls.h) that cause compilation errors during the build, which then failed. Thus the camera output could not be viewed via http portal. But this was fixed yesterday, allowing me to proceed today.

But the main point is this:
I found and tried several versions of instructions to install the required firmware to support the camera on my Raspberry Pi. At the outset, EVERY SINGLE ONE of the instructions failed at some point. Clearly the instructions themselves are not being tested. And there are too many of them. Some might work on earlier Pi models, others latest version, some work with Octopi build, others do not. Some depend on Raspian 10, others want Raspian 11. But its often not clear which.
They might have worked in the past, but no longer work. My suggestion is to hunt them down and make them right, or eliminate them. They are just confusing.


1 Like

i treid all of this and it still not working am i missing any steps? installed image of octo version: 2022–1-28 bulleye-armhflite-1.0.0.img
opened octopi-wpa-supplicant.txt and added ssid and pass on # WPA/WPA2 secured an took out 1 # saved

run thru wizard i did not hit the update.
ran driver scripts final line was reboot now?(y/n):
Your camera is IMX519,and the relevant drivers have been installed.
[email protected]:~ $

going back to octopi under control
error still pops up

webcam streem not loaded
under prefs
stream url is /webcam/?action=stream but it does not show anything
Could not retrieve snapshot URL, please double check the URL
i can type octopi.local and it load the interfave just fine so it can resolve the name.
thein installed camera settings in plugins

But it is still not working ether I get loading stream that never loads or o have the webstream not loaded…

Thanks in advance for any assistance.

after runnung:
sudo ./ -d

I get this

Cannot find the corresponding package, please send the following information to [email protected]
Hardware Revision: d03114
Kernel Version: 5.15.84-v8+
Package: 64mp_pi_hawk_eye_kernel_driver – bullseye-arm64-v5
You are using an unsupported kernel version, please install the official SD Card image(do not execute rpi-update):
Operating system images – Raspberry Pi


Please try again in a day, we are adapting the latest version.

You can also rename the subfolder 5.15.76-v8+ by 5.15.84-v8+. It works fine also.

Interesting I don’t have 5.15
There is a list of sub folders with
5.10.63-v8+ as the highest version.
Am I using an old driver ?
Or can you point me to a link for the latest ?

Unfortunately that has not worked.
the highest version I have downloaded from here:
git clone GitHub - ArduCAM/Arducam-Pivariety-V4L2-Driver: This driver is used for Arducam mipi camera with Pivariety board
in the sub folder is 5.10.63-v8+
I tried your idea, created a new folder named 5.15.84-v8+ and copied the contents from
5.10.63-v8+ into the new folder.
I did all the OS updates again and rebooted
sadly the same problem, I will now wait until you have updated the drivers for the latest Raspberry OS kernel.

Hi, any update for this one? I am facing the same situation.



Can you borrow a picture of your error? This problem should be fixed.


Thank you for this feedback. Here is the screenshot. I roll back to previous kernet but add the same result with 5.15.
Camera is working on the previous backup I have on an SDcard.


Let me explain first that renaming the version is not a recommended operation, because the kernel versions compiled by them are not the same. It may happen that some versions can be used in common, but this is not a stable and effective solution.If you have performed relevant operations, please restore the state.

Then, I need some information

Please reboot your device and execute the following command:

wget -O arducam-camera-bug-report
chmod +x ./arducam-camera-bug-report

This will output an arducam-bug-report.txt in the current directory.

Please send me this file as an attachment.
If the file is not easy to upload, you can also upload the google cloud disk.

Here is the link:


Can you update the kernel?
Raspberry Pi added the media-contoller part after 5.10.93, which should be the problem.

sudo apt-get update
sudo apt-get upgrade

then reboot

After updating the new kernel, you need to reinstall the 64mp driver.


It is very unclear for me.
I Install the latest 5.15 release:

Linux raspberrypi 5.15.92-v8+ #1627 SMP PREEMPT Mon Feb 6 12:35:20 GMT 2023 aarch64 GNU/Linux

And get the following message:

Cannot find the corresponding package, please send the following information to [email protected]
Hardware Revision: c03111
Kernel Version: 5.15.92-v8+
Package: 64mp_pi_hawk_eye_kernel_driver -- bullseye-arm64-v5
You are using an unsupported kernel version, please install the official SD Card image(do not execute rpi-update):

Which kernel version should we use. It could be interesting to add this in the script to install the proper validated kernel:

sudo rpi-update f5c4fc199c8d8423cb427e509563737d1ac21f3c

Can you let me know what is the latest valid kernel version for this driver?

Ok I managed to find a kerne suitable for the installation. But unfortunatly still the same.