init camera status = 4099 on IMX298 (16 MP) ArduCAM running on Pi 4B 8GB

Good day all,

I am trying to get an IMX298 (16MP) ArduCAM to run on a new Raspberry Pi 4B 8GB. I followed the instructions on the ArduCAM website initially and then re-ran the installation with the additional steps set out for the Pi 4B on the GitHub website. I keep getting a message as follows:

Open camera…

init camera status = 4099.

I cannot find any information on what the 4099 status means or what could be preventing the camera from initialising. I’m not sure whether it’s something I’m doing wrong or whether it’s a compatibility issue with the new 8GB Raspberry Pi. Any help would be appreciated.





Don’t worry and I will try my best to help you.

It seems the system doesn’t detected the sensor. What about the status when you run

camera_i2c script? get the script here

If normal, you will see the 0x1A address.

Please attach me your terminal information and I will try my best to help you.



Thank you for helping. I have tried your suggestion but only receive a message “command not found”. I also tried running it as sudo but no luck with that either. I can see camera_i2c in the utils sub-directory and have checked that i2c is enabled in the Raspberry Pi configuration settings but it doesn’t run.

Please let me know if you need any other details, as I’m not sure what you need from the terminal information.


It seems it does not have operation permission. Please use ‘sudo chmod +x camera_i2c’ to git the permission.


Thank you. I tried this and still had the same issue.

I have since tested the camera on a Pi Zero W and it worked fine after I installed the software according to the instructions. I have reinstalled all the software for the Pi 4B 8GB but still have the same problem.


Hi, I have the same issue with RPi4 8GB on Arducam OV9281. It worked fine on RPi4 4GB and but on RPi8GB I’m getting “init camera status = 4099” even after clean reinstallation and so on. Have you tested it on RPI4 8GB?


I haven’t tested it on RPI4B 8G platform, Can you tell me the hardware platform’s version the demo print?

Maybe the driver does not add the version support. I can add it to try.

Sorry for my late reply due to our Dragon Boat Festival holiday.

Thank you, no problem.

I ran the cpuinfo command and got the following information that I think is what you are looking for. Please let me know if you need anything else.

Hardware: BCM2835

Revision: d03114

Model: Raspberry Pi 4 Model B Rev 1.4



I have add the platform support just now. Please download new code to retry. Don’t forget to run make install to install the new lib.


Let me know if you need more help.

Works for me!!! Thanks a lot for fast and accurate response.

Excellent, thank you. It’s working now.

You are welcome.

Let me know if you need more help.


Thank you, I will do. I am hoping the camera will be very useful.


Arducam will recommend the best camera solution based on customer’s application need.

Thank you. I did quite a lot of research before buying this one and expect it will do the job well now that it’s working.


If there is any need, please contact me in time.


I’m experiencing the same issue on RPI 4B 4GB Rev. 1.4

Hardware: BCM2711

Revision: c03114

Could you please help?




Of Course, I have updated the libarducam_mipicamera lib and you can download our latest lib to retry.


Thank you very much :slight_smile: