IMX477 on bullseye with octopi not working

  1. Where did you get the camera module(s)? amazon

  2. Model number of the product(s)? IMX477

  3. What hardware/platform were you working on? raspberry pi 4 bullseye OctoPrint version : 1.8.6
    OctoPi version : 1.0.0

  4. Instructions you have followed. (link/manual/etc.) all sorts of internet guides trying to diagnose this thing. I can get my other pi cameras to work fine.

  5. Problems you were having? Camera has power as the IR sensor will trigger when you place a hand in front of it.

  6. The dmesg log from your hardware?
    [email protected]:~ $ libcamera-hello
    Preview window unavailable
    [0:00:27.366486852] [937] INFO Camera camera_manager.cpp:299 libcamera v0.0.3+40-9b860a66
    [0:00:27.422415778] [938] INFO RPI raspberrypi.cpp:1425 Registered camera /base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media0 and ISP device /dev/media2
    [0:00:27.423345685] [937] INFO Camera camera.cpp:1028 configuring streams: (0) 2028x1520-YUV420
    [0:00:27.423834704] [938] ERROR V4L2 v4l2_videodevice.cpp:1047 /dev/video0[12:cap]: Unable to set format: Device or resource busy
    ERROR: *** failed to configure streams ***

I know it sees it
[email protected]:~ $ vcgencmd get_camera
supported=1 detected=0, libcamera interfaces=1

  1. Troubleshooting attempts you’ve made? I have tried altering the config file, adding code, taking code away.

  2. What help do you need? I need help getting this thing to work. I think its a problem with the camera, ive tried contacting support and everything they have told me to do I have done.

First, please run the command:
systemctl status webcamd.service to check if your webcam is open.

If it is running, please close it by the command below:
systemctl stop webcamd.service

Then give it a try again.