IMX 219 Camera can not work after installed ArduCam ToF camera driver!

  1. Where did you get the camera module(s)?

  2. Model number of the product(s)?
    ToF Camera

  3. What hardware/platform were you working on?
    Jetson Nano

  4. Instructions you have followed.

  5. Problems you were having?

There are two CSI slots for cameras on my Jetson Nano board. I intend use one slot for
Arducam ToF Camera and one slot for IMX 219 Camera. Before I install Arducam ToF Camera
driver or SDK, the IMX219 camera works fine. After I installed Arducam ToF Camera driver, the Arducam ToF camera works fine, but the system can not detect IMX219 camera any more.

  1. The dmesg log from your hardware?

[ 0.000000] Booting Linux on physical CPU 0x0
[ 0.000000] Linux version 4.9.140-tegra ([email protected]) (gcc version 7.3.1 20180425 [linaro-7.3-2018.05 revision d29120a424ecfbc167ef90065c0eeb7f91977701] (Linaro GCC 7.3-2018.05) ) #2 SMP PREEMPT Mon Jul 13 13:19:50 CST 2020
[ 0.000000] Boot CPU: AArch64 Processor [411fd071]
[ 0.000000] Kernel command line: tegraid= [email protected] section=512M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 [email protected] video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,2 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 [email protected] core_edp_mv=1075 core_edp_ma=4000 [email protected] is_hdmi_initialised=1 earlycon=uart8250,mmio32,0x70006000 root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 quiet root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0
[ 1.005776] falcon 54340000.vic: initialized
[ 1.007115] falcon 544c0000.nvenc: initialized
[ 1.008477] falcon 54380000.nvjpg: initialized
[ 1.012858] tegra_cec 70015000.tegra_cec: dt=1 start=0x70015000 end=0x70015FFF irq=97
[ 1.012903] tegra_cec 70015000.tegra_cec: Enable clock result: 0.
[ 1.012936] tegra_cec 70015000.tegra_cec: tegra_cec_init started
[ 1.013020] tegradc tegradc.0: disp0 connected to head0->/host1x/sor1
[ 1.013152] display board info: id 0x0, fab 0x0
[ 1.013211] generic_infoframe_type: 0x87
[ 1.013239] tegra_cec 70015000.tegra_cec: cec_add_sysfs ret=0
[ 1.013244] tegra_cec 70015000.tegra_cec: probed
[ 1.013375] tegradc tegradc.0: DT parsed successfully
[ 1.013428] tegradc tegradc.0: Display dc.ffffff800ab80000 registered with id=0
[ 1.013983] tegradc tegradc.0: Bootloader disp_param detected. Detected mode: 1920x1080 (on 0x0mm) pclk=148350781

[ 1.354087] tegra-asoc: sound: ADMAIF1 ↔ ADMAIF1 mapping ok
[ 1.354219] tegra-asoc: sound: ADMAIF2 ↔ ADMAIF2 mapping ok
[ 1.354347] tegra-asoc: sound: ADMAIF3 ↔ ADMAIF3 mapping ok
[ 1.354473] tegra-asoc: sound: ADMAIF4 ↔ ADMAIF4 mapping ok
[ 1.354614] tegra-asoc: sound: ADMAIF5 ↔ ADMAIF5 mapping ok
[ 1.354746] tegra-asoc: sound: ADMAIF6 ↔ ADMAIF6 mapping ok
[ 1.354874] tegra-asoc: sound: ADMAIF7 ↔ ADMAIF7 mapping ok
[ 1.355028] tegra-asoc: sound: ADMAIF8 ↔ ADMAIF8 mapping ok
[ 1.355154] tegra-asoc: sound: ADMAIF9 ↔ ADMAIF9 mapping ok
[ 1.355280] tegra-asoc: sound: ADMAIF10 ↔ ADMAIF10 mapping ok
[ 1.366820] u32 classifier
[ 1.366821] Actions configured
[ 11.072697] fuse init (API version 7.26)
[ 11.111736] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 11.111748] Bluetooth: BNEP socket layer initialized
[ 12.408000] tegradc tegradc.0: unblank
[ 12.408197] tegradc tegradc.1: blank - powerdown
[ 118.798446] Error: Driver ‘imx219’ is already registered, aborting…

  1. Troubleshooting attempts you’ve made?

I tried to compile IMX219 driver as a kernel module. But when I insmod the imx219.ko,
it report “insmod: ERROR: could not insert module imx219.ko: Device or resource busy”.

  1. What help do you need?

How can I make the Arducam ToF camera and IMX 219 camera works simultaneously?


You need to use to change the configuration
Jetson-io - Arducam Wiki

use our version

select combination

@Edward According your instructions, Now my ToF cmaera and IMX219 camera can works simultaneously. Thanks for your help!


Gald to hear that