HQ cam + 16 mm lens + Arducam UVC adaptor gives black picture

1.Which seller did you purchase the product(s) from?
Pi Hut
2.The Model number of the product(s) you have purchased?

3.Which Platform are you using the product(s) on?
Mac
4.Which instruction are you following?

5.Has your product ever worked properly?
Not really, but directly to an raspberry pi it gave me a good image
6.What problems are you experiencing?
I am trying to connect the HQ camera with the 16 mm lens to my Mac with the Arducam UVC adaptor. It shows up in the system, both in teams and photobooth, but it just shows me a black picture. If I direct it to direct light it shows some light in the darkness, but nothing more. Here is some pictures.I have tried it directly with the cameracable into the cameraport on the raspberry pi B2+ and it works there. Pictures is without CS adapter, but no difference when instlaled.

 

Some pictures.

 

What I see with the aperture at 16

What I see with the aperture on 8

What I see when I point it at me with any aperture

What I see when connected directly to the camera port

Any advice?
7.What attempts at troubleshooting have you already made?
Tested on raspberry pi directly
8.How would you like us to help you?
Suggestions and advice to make the Arducam USB solution work.

Dear Customer,

Sorry for my late reply. I have not received your images now. Would you like to resend it to me again?

Feel free to let me know if you need more help.

 

 

Sorry, the pictures did not get there.

What I see with the aperture at 16

What I see with the aperture on 8

What I see when I point it at me with any aperture

What I see when connected directly to the camera port

Any ideas?

Dark images happen when the shutter speed is too fast or the aperture isn’t open enough. Be careful of your camera’s automatic settings. Most cameras tend not to pick the right ones by default. If your camera creates an image that is too dark, use EV to bump up the brightness.

Thank you for the answer. I am not setting the shutterspeed and I am, as you can see above, using all the different appertureopenings with out any change. The camera works as it should when connected to a raspberry, but not when I am connecting it to the Arducam UVC.

Hi,

Our UVC adapter board uses the strategy of automatic exposure and no frame drop. The Raspberry Pi camera can shoot brighter because of the increased gain and lower frame rate.

So how do I make my camera usable?

Hi,

Allow me ask you some problems.

Where is the scene you used? Normal light environment or dark environment with lower brightness?

Is the same lens used when using the UVC adapter board and directly using it on the Raspberry Pi?

Did you adjust the aperture and focus?

Can you send us your detailed operating steps and operating procedures via video?

Hope you answer our questions truthfully so that we can better help you.

Hi, the camera was userd in my room, as I did not move an inch or change anything from where I took the photo when connected to the RPI. It is the same lens as when connected to the RPI. I did not change the focus, but as you can see from the pictures above I did change the apperture quite a lot, but just on the lens, not in the system settings in any way shape or form.

Operating procedures when connected to the arducam:

  1. connect lens with and without cs adaptor to the camera and then to the Arducam UVC adaptor.

  2. Connect the arducam to the mac with the supplied cable

  3. test camera.

 

Operating procedures when connected to the raspberry pi

  1. connect lens to the camera and then with cable to the raspberry pi

  2. take photo using command raspistill -o Desktop/cam.jpg

Hi,

Can you use the camera with UVC adaptor on windows os or raspberry pi?

I want to make sure if the mac cause the black picture.

If black pictures still on other platform, I will send you a adaptor firmware to update it.

There is no change when I tried it on windows, with different appertures and so on.

Hi,

We will send you a updated firmware via email, you can try it.

That worked. Thank you very much :smiley:

Hi I am having this same problem with Arducam 477 IRCut + Arducam UVC board. Exactly the same as the previous user. It is fine when directly connected to raspberry pi through camera connector, but I see very dark image when connected to raspberry pi via UVC board.

Could I please get the updated firmware?