How to use JPG format

I’m using USB3.0_UC-425_Rev.C+UC-489 and OV5647 Camera. The configuration files you provide use RAW format. Now I’m struggling with bandwidth and I want to use JPG format.
I’ve tried JPG format by changing the configuration file but doesn’t work.

Do you know is it possible to use JPG format and How?

OV5647 is likely to be support only Raw format

.

Hi,

Yes, at present, we just have ov5647 raw config.

Hello,

I finally get OV5640 now but there is no configuration file for JPEG.

Could you help me to make a configuration file of JPEG format?

I’d like 2592 * 1944 resolution at 15fps.

I’m using USB3.0_UC-425_Rev.C+UC-628_Rev.B.

Hello,

Please refer to this config file I attached for you.

 

Hello,

Sorry but I can’t find it.

Hello,

Sorry because the format is not supported. I have send you again

 

Hello,

Thank you for your response but the configuration file doesn’t work on my PC.

I got these:

Error capture image, rtn_val = 65314

Error capture image, rtn_val = 65316

Error capture image, rtn_val = 65314

Error capture image, rtn_val = 65316

Error capture image, rtn_val = 65314

Error capture image, rtn_val = 65316

Hello,

Are you using our USB 3.0 board? Sorry to tell you the usb3.0 does not support the jpeg configure. This is used for USB2.0 board.

 

Hello,

I have tested it on USB2.0-UC391-Rev.B but I got bellow errors:

[email protected]:~/Projects/ArduCAM_USB_Camera_Shield/Linux_x86/Cpp/Streaming_demo(master)$ sudo ./ArduCam_Demo ~/Downloads/OV5640_MIPI_2Lane_JPG_2592x1944_15fps/OV5640_MIPI_2Lane_JPG_2592x1944_15fps.cfg
device num:1
index: 0 Serial:AU2S-2008-0001
Serial: AU2S-2008-0001
capture thread create successfully.
read thread create successfully.
Capture began, rtn_val = 0
Error capture image, rtn_val = No image data
65317
No image data
No image data
No image data
No image data

Hi,

Please attach me your sensor’s image. I need to ensure your 5640 sensor type.

 

Hi,

I’m using this: https://reference.digilentinc.com/reference/add-ons/pcam-5c/start

The camera you are using is not our camera and I am not sure the hardware is compatible. What’s more, our USB2.0-UC391-Rev.B does not support mipi interface. Please attach me your hardware connection and I will help you check it in detail.

 

Sorry, It’s not Rev.B but Rev.E

Please attach me your hardware connection (USB 2.0 Rev.E + OV5640) diagram. and I will invite our hardware engineer to help you check it in detail.

Hi,

Unfortunately, I can’t attach any files or images because of my company’s security issue.
Now I’m trying to buy your OV5640 camera. I’ll contact you again after getting it. Thank you so much for your support.

OK, Let me know if you need more help.