How to use Arducam 1MP (OV9782 Color) Quad-Camera Bundle Kit with GStreamer?

What is the correct GStreamer pipeline to stream the video output from the Arducam 1MP (OV9782 Color) Quad-Camera Bundle Kit?

This is really interesting question, i am also interested in that. Did you find solution already ?

Hi erikkocky,
I think Arducam OBISP board driver can meet your requirement. After you have installed the Arducam obisp driver. you can use arducamstill tool to get image and put it to the stdout. Then you can use gstreamer server to grab the image through pipline.
On raspberrypi :
arducamstill -t 0 -pixfmt RGGB -w 5120 -h 800 -e h264 -o stdout | nc -l -p 5000

On your windows:
gst-launch-1.0 -v tcpclientsrc host=x.x.x.x port=5000 ! decodebin ! autovideosink

Hi Ivbin
thanks for the answer
with command

arducamstill -t 0 -pixfmt RGGB -w 5120 -h 800 -e h264 -o stdout | nc -l -p 5000

i get

mmal: mmal_vc_port_enable: failed to enable port vc.ril.video_encode:in:0(I420): EINVAL
mmal: mmal_port_enable: failed to enable port vc.ril.video_encode:in:0(I420)(0x12629e0) (EINVAL)

I tried also different --pixelFormat such as 'pRAA', RG10' and then I get nothing like code is stuck.


and on my windows I can see just

[email protected]:~$ gst-launch-1.0 -v tcpclientsrc host=10.126.128.51 port=5000 ! decodebin ! autovideosink
Setting pipeline to PAUSED …
Pipeline is PREROLLING …

Also you talking about images but we need to stream video.
Thanks

Thanks for the reply, Ivbin. I also encounter the same issue… Thanks!

Hi,
Strange phenomenon.
Take it easy. Today I will test it and repy you as soon as possible.

1 Like

arducamstill.rar (45.7 KB)

Hi,
I have helped you update arducamstill tool to support that. Please download the latest arducam still tool to retry.

Where can I find this tool? Thanks

Hi,
I have loaded the latest arducamstill to the forum and our github lib. You can get it from https://github.com/ArduCAM/Arducam_OBISP_MIPI_Camera_Module/tree/master/Release/arducamstill
It is due to for the video encoder, it does not support for more than 1080P resolution. We need to crop the image.

I believe if you download and reinstall driver from this git it will work. I can try it tomorrow.

Hi Ivbin,

it works now thanks for fix, although i receive just an image and i need to stream the video, is it just a problem with wrong pipeline for gstreamer ? Also recieving stream just from one camera not all 4 of them.

Thanks a lot for the fix and response

Hi,
It maybe due to the image cropped. The issue is due to rpi’s isp component does not support video which is more than 1080p. We must crop the image.

Can I maybe resize the image to 1920 x 1080 and then send it ? Is there some proper way how to do it ?

Hi,
At present, I don’t have a better way to resize it. It need the sensor supports 1/4 binning mode and we can resize each camera’s size to 1/4 from original size. So we can get a suitable resolution, which seems not easy. I think we can contact through email. Please send your detail issue to our [email protected].