Higher resolutions on imx519 module

I have an imx519 autofocus 16 MP that I got recently. I got the script from arducam and got the driver, libcamera_dev, and libcamera_apps with it. All of the updates are installed on the pi. My other cameras all work fine but I’m having an issue with the new imx519.

Everything seems to work fine with the new camera and apps. But when I try to take a video larger that 1920x1080, the camera fails to open. I can choose the modes larger than 1920:1080, but when the --width and --height are set larger than that, the window opens and immediately closes.

This is what it says:

[email protected]:~ $ libcamera-vid --autofocus-mode auto -f --rotation 180
-t 10000 -o fff.h264 --mode 3840:2160 --width 3840 --height 2160
Overriding H.264 level 4.2
Made X/EGL preview window
[0:56:28.760760894] [1612] INFO Camera camera_manager.cpp:299 libcamera v0.0
.0+4135-f8a5e271
[0:56:28.768851390] [1615] WARN CameraSensorProperties camera_sensor_propert
ies.cpp:190 No static properties available for ‘imx519’
[0:56:28.769045975] [1615] WARN CameraSensorProperties camera_sensor_propert
ies.cpp:192 Please consider updating the camera sensor properties database
[0:56:28.974831643] [1615] WARN RPI raspberrypi.cpp:1308 Mismatch between Un
icam and CamHelper for embedded data usage!
[0:56:28.977040935] [1615] INFO RPI raspberrypi.cpp:1425 Registered camera /
base/soc/i2c0mux/[email protected]/[email protected] to Unicam device /dev/media3 and ISP device
/dev/media2
Stream configuration adjusted
[0:56:28.979316583] [1612] INFO Camera camera.cpp:1026 configuring streams:
(0) 3840x2160-YUV420 (1) 3840x2160-SBGGR10_CSI2P
[0:56:28.979988464] [1615] INFO RPI raspberrypi.cpp:805 Sensor: /base/soc/i2
c0mux/[email protected]/[email protected] - Selected sensor format: 3840x2160-SBGGR10_1X10 - Sele
cted unicam format: 3840x2160-pBAA
ERROR: *** failed to start output streaming ***

Any tips or hints? Is it the module? My other cameras go above 1080p so I’m a little confused. Thanks for any help.

Edit: It’s on a Pi 3b if that makes a diference.

Small update: Maybe I was confused about the cameras output ability. A little more time with it and it seems like every resolution works with photos, all the way to the max resolution. If I change the --mode sizes larger than 1080p on videos, the crop clearly changes and there is more detail but the output stays at 1080. Is this normal, expected behavior? Is the video output limited to 1080?

uname -a
Linux raspberrypi 5.15.84-v8+ #1613 SMP PREEMPT Thu Jan 5 12:03:08 GMT 2023 aarch64 GNU/Linux

cat /etc/os-release
PRETTY_NAME=“Debian GNU/Linux 11 (bullseye)”
NAME=“Debian GNU/Linux”
VERSION_ID=“11”
VERSION=“11 (bullseye)”
VERSION_CODENAME=bullseye
ID=debian
HOME_URL=“https://www.debian.org/
SUPPORT_URL="https://www.debian.org/sup

cat /proc/meminfo
MemTotal: 943712 kB
MemFree: 101144 kB
MemAvailable: 352352 kB
Buffers: 11316 kB
Cached: 285728 kB
SwapCached: 5888 kB
Active: 183372 kB
Inactive: 492332 kB
Active(anon): 18344 kB
Inactive(anon): 374224 kB
Active(file): 165028 kB
Inactive(file): 118108 kB
Unevictable: 16 kB
Mlocked: 16 kB
SwapTotal: 102396 kB
SwapFree: 18428 kB
Dirty: 196 kB
Writeback: 0 kB
AnonPages: 372948 kB
Mapped: 213284 kB
Shmem: 13896 kB
KReclaimable: 26256 kB
Slab: 61380 kB
SReclaimable: 26256 kB
SUnreclaim: 35124 kB
KernelStack: 5392 kB
PageTables: 12568 kB
NFS_Unstable: 0 kB
Bounce: 0 kB
WritebackTmp: 0 kB
CommitLimit: 574252 kB
Committed_AS: 2339532 kB
VmallocTotal: 259653632 kB
VmallocUsed: 16692 kB
VmallocChunk: 0 kB
Percpu: 688 kB
CmaTotal: 409600 kB
CmaFree: 71784 kB

cat /boot/config.txt

For more options and information see

Raspberry Pi Documentation - Configuration

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode#hdmi_safe=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border#overscan_left=16

#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=1280
#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output

#hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)

#hdmi_group=1
#hdmi_mode=1

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes

#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=spi=on
dtparam=i2c_vc=on

Uncomment this to enable infrared communication.

#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on

Automatically load overlays for detected cameras

camera_auto_detect=1

Automatically load overlays for detected DSI displays

display_auto_detect=1

Enable DRM VC4 V3D driver

dtoverlay=vc4-kms-v3d,cma-384
#dtoverlay=vc4-kms-v3d

max_framebuffers=2

Run in 64-bit mode

arm_64bit=1

Disable compensation for displays with overscan

disable_overscan=1

[cm4]

Enable host mode on the 2711 built-in XHCI USB controller.

This line should be removed if the legacy DWC2 controller is required

(e.g. for USB device mode) or if USB support is not required.

otg_mode=1

[all]

[pi4]

Run as fast as firmware / board allows

arm_boost=1

[all]
enable_uart=1
gpu_mem=64
#dtoverlay=imx519
#dtoverlay=arducam_64mp
#dtoverlay=arducam

dtoverlay=imx519

I tried to post the dmesg out put but your fourm wont let me post it. I can only guess it is too long to post, the warning message is cut off at the top of the screen. Only the ok button is visible. Is there a part of it you’d like? I also didn’t include the photo of the cables. It works so I don’t think it’s necessary. Anything else I can include?

If I can give any further info, please let me know.