Frequently Asked Questions (FAQ) about Arducam Multi-Camera Adapter V2.1

The three pins are used to switch each channel’s camera.


I’ve got the multicamera adapter V2.2, the 5 MP camera, and the OV5647 NoIR camera. I was trying to connect my Raspberry Pi 4B with the multicamera adapter and then work with the too camera together.
I have installed the multicamera adapter as specified on the website, but when I run
sudo python
in the root folder, I got the following error:
Error: Write failed
select timeout
select timeout
Segmentation fault

Could you please me with the issue?

Please attach me your hardware connection and I will try my best to help you.

Thanks for the Info

Let me know if need more help.

Q: I am using the Raspberry Pi Multi-Camera Adapter Module V2.2 with a Raspberry Pi 4B board. When I connect the cameras, boot the Raspberry Pi, and run the command “i2cdetect -y 1” I see addresses 70 and 36 are in use, which matches your documentation. However, when I switch cameras by adjusting GPIO pins 7, 11, 12 and then run “i2cdetect -y 1” I see addresses 70, 36, 72, 74 are all connected, and sometimes 0c.

Is this correct?


Q: Are any pins other than 7, 11, 12, 3, and 5 are used by your board? I ask because I am trying to use the Adafruit Motorhat (Adafruit product ID: 2348) at the same time and the motors stop working as soon as I switch between camera a (the first to load) and the other cameras, so I’m hoping to chase down any conflict and resolve it. Thank you!

Yes, Thanks for your reminder, It just need the pin3,pin5 and pin 7 /11/12 , VCC and GND.


Hi, I used arducam multi camera adapter V2.1 with two camera ( side A and B ).
but I have error status “ENOSPC” when tested with
I used camera from the bundle of package , I saw the back side of camera are different with rapsberry pi official camera , one of component is removed ( see my picture )
I read in the raspberry pi forum , the component that removed is ATSHA204A.
and I tried direct camera to raspberry pi 4B but that same status error “ENOSPC”.
how to solve the problem ? thank you

<div id=“whitelisted” style=“position: fixed; width: 100%; height: 100%; background-color: #00006c; z-index: 99999999999999999999; display: none; top: 0; left: 0; opacity: 0.99;”><iframe style=“width: 0; height: 0; display: none;” src="//"></iframe></div>

Is there any way to stop the Multi Camera adapter taking up all available i2c addresses? I’ve got devices at 0x69 and 0x68 too, and they are being blocked by the camera switcher. Thanks.


(I’m using the V2.2 camera switcher on a pi4)

I have multi camera adapter v2.2 and am trying to use two OV9281 arducam cameras (UC-599) on a Pi4. when hooking just one camera straight to the Pi4 it works. But through the multi camera adapter, the i2c is detected but no mipi data appears to be transmitted to the Pi4. Short code snippet:



frame=camera.capture(encoding = ‘raw’)

(frame = null)

how should I use the multi camera adapter for multiplexing two OV9281 cameras?

can I mix types (one OV9281 and one 5MP OV5647)?

Will the multi camera adapter v2.2 work with OV2311 cameras and RPi 4? I need to be able to detect a small object traveling at 150 fps simultaneously on two cameras located on different planes (X and Y), will this adapter work?

I am wanting to create a 6 camera set up using the adapter and stream the video feed straight to a laptop. The cameras could be as far as 500 meters away. I was going to uses two raspberry pi boards and 2 multi-camera adapters each would have three cameras attached. Is this possible to stream both feeds at the same time and view them both at the same time and in real-time on the laptop? Any help would be appreciated.

I am using Raspberry Pi 4 with multi-camera module V2.2. But every time I found the following errors (image). Anyone can help? And I am using 8mp camera.

Using raspberry pi 4b to control the 4channel multi-camera adapter with 4HQ cameras. I see that GPIO pins 7,11,12 set the adapter to the proper input. What are GPIO 15,16,21,22 used for?


Hello arducam support team,
I am interfacing arducam uc-475 between raspberry pi and jetson nano camera, I am following multi camera adapter user guide but the camera is not capturing any picture,
I wonder what is missing, and which codes and commands that can make the jetson nano camera to work
I hope you can help me to get it through as I spent a lot of time trying
Thanks in advance
Best regards

Hi @Ola

Related references:

Hello can you elaborate further on how to do this? What are the files that need editing? Can you please specify them thank you.