Failed IMX519 installation on RPI Zero 2 W

  1. Where did you get the camera module(s)?
    Kickstarter campaign

  2. Model number of the product(s)?

  3. What hardware/platform were you working on?
    RPI Zero 2 W

  4. Instructions you have followed. (link/manual/etc.)

  5. Problems you were having?
    Install fails at ./ -p imx519_kernel_driver command:

install: target ‘/lib/modules/5.10.92-v8+/kernel/drivers/media/i2c/’ is not a directory: No such file or directory
install: target ‘/lib/modules/5.10.92-v8+/kernel/drivers/media/i2c/’ is not a directory: No such file or directory
depmod: ERROR: could not open directory /lib/modules/5.10.92-v8+: No such file or directory
depmod: FATAL: could not search modules: No such file or directory

  1. The dmesg log from your hardware?
    dmesg.txt · GitHub

  2. Troubleshooting attempts you’ve made?
    Install fails after running sudo apt-get -y upgrade
    Works if I dont upgrade

  3. What help do you need?
    Guessing there’s an update for the rasberry pi, which is not supported with the install script.
    Noticed “Unpacking raspberrypi-kernel (1:1.20220308-2) over (1:1.20220120-1)” … when upgrading.

You can try reinstalling, we just uploaded the 5.10.103 kernel driver.

Hmm, still get the same error when upgrading a fresh install, then installing the camera.
Install works perfectly if I dont upgrade.
Im using rapberry pi os lite 64-bit.

Hi, we have tested the 5.10.92 and 5.10.103 kernel drivers and there are no problems. We recommend that you can re-burn and install the latest version of the Raspberry Pi image.