Driver support for Pi HQ Camera

Do you have plans to provide a driver for the Pi HQ or other products to enable its operation with the Nano?

Do you know of any drivers that will support it.



We had a plan to support HQ camera on the Jetson Nano, and it’s a part of our Jetvariety Project. In this project, we use a kernel camera driver for all cameras, and you need 1)an Arducam certified camera module, 2)the Jetvariety adapter board, and 3)the driver to work. A driver alone can’t currently enable the Pi HQ camera to work on the Jetson Nano from our solution.

We’ve already made it possible to run the IMX477 - not limited to the Pi HQ, but also Arducam IMX477 cameras- on the Jetson Nano.

What do I need to purchase to get my HQ working with my Nano?


@Bills Before you proceed with any purchasing, we need to make it clear about how the HQ camera will work on the Nano.

Although we’re able to get it up and running on the Jetson Nano, only RAW data is presented. This means it will not run as smoothly as on a Raspberry Pi, and you might need your own software to process the raw data to meet you needs.


This means it will not run as smoothly as on a Raspberry Pi, What does this mean?

Will it provide real time full color viewing and capture with standard software libs?

What won’t it do that I could need for typical applications?

Do you have a sample 4K image captured on the Nano with the HQ and your interface board?

By the way i have bought 2 of your lenses, Nikor lens adapter, the CSI - HDMI adapter.

I really like the 4 - 12 zoom, The Nikor adapter works with all my Nikon lenses.


I asked about this on Nvidia’s forum too. RidgeRun is working on a driver too. They apparently have success with it, but they haven’t released the driver yet.

It’s not to work with standard software libs. Instead, it supports standard V4L2(Video4Linux2) framework under the Project Jetvariety.

What’t won’t it do? Well, with only RAW data available, there is no Auto white Balance, Auto Gain, Auto Exposure, or JPEG compression, so for those controls the parameters need to be manually toggled. There is no hit-enter-and-capture commands like raspistill or raspivid. Other software like OpenCV would be used to get a slice of the video feed.

Do we have a sample 4k image captured? Currently we’ve only had programs to display the video feed, and some video containing the demonstration of the IMX477 on Jetson Nano (with our own Arducam IMX477 by the way).

The whole efforts we’ve made for the IMX477 to work with the Jetson Nano is to prove and add up to the compatibility of the Jetvariety project, as well as open up the opportunity for the RPi users to try their HQ module on the Jetson Nano. We would usually recommend 16MP IMX298 and 18MP AR1820 if a user want the camera module for the Jetson Nano only.

and thank you for buying our products!


Do they have new release driver messages?

Hi everyone, We are glad to announce the early-version of the IMX477 Raspberry Pi HQ Camera Compatibility in our Github repo: You can find documentation about how to build, install and use the driver. The first version of the ISP config file …

So it looks like things are moving in the right direction This from the NVidia Form

Great to hear that.


I am trying to use the camera B0249 with Jetson Nano dev. kit.

Here there is my software versions:

uname -a
Linux dvjes-nanokit43 4.9.140-tegra #1 SMP PREEMPT Mon Dec 9 22:47:42 PST 2019 aarch64 aarch64 aarch64 GNU/Linux

cat /etc/nv_tegra_release

R32 (release), REVISION: 3.1, GCID: 18186506, BOARD: t210ref, EABI: aarch64, DATE: Tue Dec 10 06:58:34 UTC 2019


I followed these steps:

– When I tried to install driver using the script I got the following output:

Cannot find the corresponding deb package, please send the following information to [email protected]
Kernel version: 4.9.140-tegra-32.3.1-20191209225816
Jetson type: Nano (Developer Kit Version)


– In this repository:

I don’t find the correct version as all packages are arducam-nvidia-l4t-kernel_4.9.140-tegra-32.3.1-2020XXXX and mine should be arducam-nvidia-l4t-kernel_4.9.140-tegra-32.3.1-2019XXXX.

I tried with all packages arducam-nvidia-l4t-kernel_4.9.140-tegra-32.3.1-2020XXXX but it does not work.


I can not update my system to a newer Jetpack version. Please help me.