Driver installation issues

  1. Model number of the product(s)?
    64MP autofocus quad camera kit

  2. What hardware/platform were you working on?
    Pi 4

  3. Instructions you have followed. (link/manual/etc.)
    Performed the outlined instructions for setting up the 64MP autofocus camera(s).
    i.e. running the bash scripts, installing libcamera-dev and libcamera-apps, and installing the 64mp_pi_hawk_eye_kernel_driver, installing the focus adjustment software, and editing the configuration through /boot/config.txt
    Camarray – Arducam 16MP / 64MP Quad-Camera Bundle Kit - Arducam

  4. Problems you were having?
    Driver installation fails.

  5. The dmesg log from your hardware?

    Notice: There is also no /dev/video0

  6. Troubleshooting attempts you’ve made?
    I’ve tried multiple different cameras, Pis, SD cards and I run into errors every time

  7. What help do you need?
    I want to know what part of the setup needs fixing so that I can get the camera(s) to work.


This is because the camera is not connected properly.
Please reboot to connect the camera and send me the connection diagram to see.

Hey Edward,

Here are a couple pictures of my connection as requested.(I’m making 2 posts due to being allowed only 1 media item per post).

Furthermore, I kept troubleshooting and was able to get a black window to appear, but no actual stream.
Also, /dev/video0 now exists and running dmesg | grep arducam now outputs "Device found Arducam 64MP." and "Consider updating driver arducam_64mp to match on endpoints"

here is the second of the two pictures of my connection.

NVM I figured out what the issue was, I had to change it to a single channel instead of the default 4 channels. :slight_smile:


Switching channels is also a way of thinking. If you want to use 4 channels, make sure that A, B, and C, D each have at least one camera in the group.