Driver Installation error for Arducam B0348 OG02B10 camera on raspberry pi

Hi Arducam support team,
I am developing multiple camera based monitoring system for the moving vehicle, where I am using 120 fps supported B0348 camera with raspberry pi 4. As per given manual, I have installed all the driver, library, kernel without any error. But while testing it is giving error and not working with gstreamer.

System detail

[email protected]:~ $ uname -a
Linux raspberrypi 5.15.76-v7l+ #1597 SMP Fri Nov 4 12:14:58 GMT 2022 armv7l GNU/Linux
[email protected]:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
NAME="Raspbian GNU/Linux"
VERSION_ID="11"
VERSION="11 (bullseye)"
VERSION_CODENAME=bullseye
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
[email protected]:~ $ cat /proc/meminfo
MemTotal:        3748352 kB
MemFree:         3087628 kB
MemAvailable:    3404340 kB
Buffers:           23404 kB
Cached:           426144 kB
SwapCached:            0 kB
Active:            89120 kB
Inactive:         461176 kB
Active(anon):       1104 kB
Inactive(anon):   127096 kB
Active(file):      88016 kB
Inactive(file):   334080 kB
Unevictable:       20400 kB
Mlocked:              16 kB
HighTotal:       3080192 kB
HighFree:        2512100 kB
LowTotal:         668160 kB
LowFree:          575528 kB
SwapTotal:        102396 kB
SwapFree:         102396 kB
Dirty:                 0 kB
Writeback:             0 kB
AnonPages:        121220 kB
Mapped:           139348 kB
Shmem:             27452 kB
KReclaimable:      18988 kB
Slab:              39996 kB
SReclaimable:      18988 kB
SUnreclaim:        21008 kB
KernelStack:        2008 kB
PageTables:         5156 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:     1976572 kB
Committed_AS:    1048780 kB
VmallocTotal:     245760 kB
VmallocUsed:        6076 kB
VmallocChunk:          0 kB
Percpu:              448 kB
CmaTotal:         327680 kB
CmaFree:          311772 kB
[email protected]:~ $ cat /boot/config.txt
# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

# Automatically load overlays for detected cameras
camera_auto_detect=1

# Automatically load overlays for detected DSI displays
display_auto_detect=1

# Enable DRM VC4 V3D driver
dtoverlay=vc4-kms-v3d
max_framebuffers=2

# Disable compensation for displays with overscan
disable_overscan=1

[cm4]
# Enable host mode on the 2711 built-in XHCI USB controller.
# This line should be removed if the legacy DWC2 controller is required
# (e.g. for USB device mode) or if USB support is not required.
otg_mode=1

[all]

[pi4]
# Run as fast as firmware / board allows
arm_boost=1

[all]
dtoverlay=arducam
gpu_mem=256
[email protected]:~ $ dmesg | grep "arducam"
[   10.142226] arducam-pivariety 10-000c: firmware version: 0x10002
[   10.658911] arducam-pivariety 10-000c: Consider updating driver arducam-pivariety to match on endpoints
[email protected]:~ $

Error while running libcamera-still -t 5000 -o test.jpg

[0:10:22.156297689] [1502]  WARN CameraSensorProperties camera_sensor_properties.cpp:174 No static properties available for 'arducam-pivariety'
[0:10:22.156377130] [1502]  WARN CameraSensorProperties camera_sensor_properties.cpp:176 Please consider updating the camera sensor properties database
[0:10:22.195667674] [1502] ERROR IPAProxy ipa_proxy.cpp:149 Configuration file 'arducam-pivariety.json' not found for IPA module 'raspberrypi'
[0:10:22.547795554] [1502] ERROR DelayedControls delayed_controls.cpp:87 Delay request for control id 0x009a090a but control is not exposed by device /dev/v4l-subdev0

Error while running Gstreamer Command

[email protected]:~/arducam $ gst-launch-1.0 libcamerasrc ! 'video/xraw,width=1920,height=1080' ! videoconvert ! autovideosink
WARNING: erroneous pipeline: could not link libcamerasrc0 to videoconvert0, neither element can handle caps video/xraw, width=(int)1920, height=(int)1080
[email protected]:~/arducam $ 

Please guide me to fix library/driver issue.

Hi,
Please change this to
camera_auto_detect=0

Hi Dion,
Thanks for quick response, I have tried what you have suggested. Unfortunately it doesn’t worked for me, still there is a error

ERROR IPAProxy ipa_proxy.cpp:149 Configuration file 'arducam-pivariety.json' not found for IPA module 'raspberrypi'

and also gstreamer pipeline not working

WARNING: erroneous pipeline: could not link libcamerasrc0 to videoconvert0, neither element can handle caps video/xraw, width=(int)1920, height=(int)1080

With libcamera app camera started working using below command

libcamera-vid -t 100000 --width 1280 --height 720 -o test.h264

This camera is 120 fps supported, but I am getting ~29.8 FPS only, why it is so?

Regards

Hi Dion,

Please guide me to fix this issue.

  1. gstreamer not working
  2. how to get 120 fps framerate