Does not work: Arducam 4 Cam Adapter Board (UC-276 Rev.C) with Raspberry Pi 4

Hi All,

I need some help configuring Arducam 4 Cameras Adapter Board with Raspberry Pi4I have connected the board like the pictures, installed repository software and drivers, but once I start the demo, everything halts after showing message “Arducam begin.”
I suppose I have to change some peripheral start addresses, but don’t know where exactly.
Please, help, I have my final project to deliver on Friday and cannot make any advances.
I have tried the jumper both in the 3V3 position, and then 5V just in case.

Best regards , thanks a lot.

1.- I have tried with the Raspberry Pi 3 (not powerful enough for my project), just to check hardware, Even if it does not start the demo, recognizes the board , SP1 and cameras, stopping after 1st camera OV2640.

2.- In both cases, If I connect ALL pins, the raspberry won’t boot, the green led stays on and booting does not start. I have to remove the 5V connector and let it boot and connect it afterwards.

I solved it:

  1. Editing file bcm283x_board_driver.h and changing Base Peripheral Address from:
    #define BCM2835_PERI_BASE 0x3F000000
    #define BCM2835_PERI_BASE 0xFE000000
    and recompile :
    sudo make
    (the new CPU is a BCM2711, but for quick and dirtiness, I didn’t change the constant name)

  2. I have to boot the Raspberry with the first two 5V pins to the board removed , once booted, connect them back.



Sorry for my later reply due to our Chinese New Year’s holiday.

Great to hear you have solved your problem. Let me know if you need more help.