Capture image using host application and Arducam Mini-2MP-OV2640 Camera Shield

I use the Windows host application to capture image using the Arducam Mini and Arduino Uno. However, no image is shown on my PC. It displays the following:

Please help to sort out the problem. Thanks.

Please check the video tutorial from


Hi Jackson. I am using the Arducam Mini-2MP-Plus. I have followed the video steps but still cannot capture the image on my PC. The video shows “SPI interface OK” (see below) but in my case I just see “COM is open” on PC. Have I missed something? Thanks.



What steps have I missed? Please help.

every single step will be the same as the video demo.

You first have to download the correct example code from the Arducam library. Can you tell me which example you have downloaded?

From your feedback, it seems like the example code is not correct or the bandrate is not match with the GUI. So there is no debug print in the GUI.

Hi Jackson.

The example I used is ArduCAM_Mini_2MP_Plus. The cam I used is Arducam-2MP-Plus. Have I chosen the wrong example?



The example you used is correct, but it can basically be inferred from the print information of the host app that the initialization of I2C or SPI failed and the program did not continue to execute. Please check your wire connection and whether the board is working properly.

Or you can change the serial port baud rate to 115200, and use the serial monitor that comes with Arduino IDE to view debug information.

Hi Jackson.

I try a new Arduino Uno board and done all the wire connection. Also try different serial port baud rates. However, the problem remains.

I suspect the new Arducam is not working. How can I check whether the cam is working properly? Thanks.


Hi TerenceTerence,

Did you test according to the method I said? The method I mentioned can infer whether there is a problem with the camera by detecting whether I2C and SPI are connected. I suggest you upload the output information of the serial monitor so that we can analyze the problem.

Hi Jackson.

I change the serial port baud rate to 115200, and use the serial monitor which display below. Please help to diagnose the problem. Thanks.

Hi Jackson,

I noticed that error message displayed when I uploading code to Arduino Uno. Display below. Hope help to sort out the problem. Thanks.

I extract the error message during the loading for your advice. Thanks.


I noticed that the baud rate set by your serial monitor is not consistent with the baud rate set in the code. Please check the debugging information output after setting the same baud rate.


I set it right. For your advice please.


It seems that the program is not executed. Please confirm that the code is successfully programmed and try to reset the button. If it still does not work, it is recommended that you replace it with a UNO for testing.

Hi Jackson

When I uploading the code to Arduino, the following error message appears. What is the problem?


The warning message in your picture may be a problem of different IDE versions, you can ignore it.

Hi Jackson,

I have tried all the methods but it still not works. Any ideas? Thanks.


Have you replaced Arduino uno for testing? Presumably from your serial output, the program you downloaded has not been executed.

Hi Jackson,

I changed a new Uno board and the problem resolved. Thank you for your support and help.


You are welcome.